summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xhkeys/xhkeys-2.2.1-r1.ebuild')
-rw-r--r--x11-misc/xhkeys/xhkeys-2.2.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xhkeys/xhkeys-2.2.1-r1.ebuild b/x11-misc/xhkeys/xhkeys-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..3ccb080471da
--- /dev/null
+++ b/x11-misc/xhkeys/xhkeys-2.2.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Assign particular actions to any key or key combination"
+HOMEPAGE="http://wmalms.tripod.com/#XHKEYS"
+SRC_URI="https://wmalms.tripod.com/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-linux_headers.patch
+ "${FILESDIR}"/${P}-CC.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin xhkeys xhkconf
+ dodoc README VERSION
+}