summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xnots')
-rw-r--r--x11-misc/xnots/metadata.xml8
-rw-r--r--x11-misc/xnots/xnots-0.2.1-r2.ebuild12
-rw-r--r--x11-misc/xnots/xnots-9999.ebuild53
3 files changed, 11 insertions, 62 deletions
diff --git a/x11-misc/xnots/metadata.xml b/x11-misc/xnots/metadata.xml
index 230858f0c0fd..91718977b34c 100644
--- a/x11-misc/xnots/metadata.xml
+++ b/x11-misc/xnots/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>desktop-misc@gentoo.org</email>
- <name>Gentoo Desktop Miscellaneous Project</name>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
</maintainer>
<upstream>
<remote-id type="sourceforge">xnots</remote-id>
diff --git a/x11-misc/xnots/xnots-0.2.1-r2.ebuild b/x11-misc/xnots/xnots-0.2.1-r2.ebuild
index 4037d3a8f0b6..295f6a4a777b 100644
--- a/x11-misc/xnots/xnots-0.2.1-r2.ebuild
+++ b/x11-misc/xnots/xnots-0.2.1-r2.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit flag-o-matic toolchain-funcs
DESCRIPTION="A desktop sticky note program for the unix geek"
HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
-SRC_URI="mirror://sourceforge/xnots/${P}.tar.gz"
+SRC_URI="https://downloads.sourceforge.net/xnots/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 -riscv x86"
IUSE="vim-syntax"
RDEPEND="
@@ -23,9 +24,10 @@ RDEPEND="
DEPEND="
${RDEPEND}
- virtual/pkgconfig
x11-base/xorg-proto
"
+BDEPEND="virtual/pkgconfig"
+
PATCHES=(
"${FILESDIR}"/${PN}-0.2.1-gcc6.patch
)
diff --git a/x11-misc/xnots/xnots-9999.ebuild b/x11-misc/xnots/xnots-9999.ebuild
deleted file mode 100644
index 3f81446e468c..000000000000
--- a/x11-misc/xnots/xnots-9999.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit flag-o-matic git-r3 toolchain-funcs
-
-DESCRIPTION="A desktop sticky note program for the unix geek"
-HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
-EGIT_REPO_URI="https://github.com/thePalindrome/xnots"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="vim-syntax"
-
-RDEPEND="
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXrandr
- x11-libs/libXrender
- x11-libs/pango[X]
-"
-
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
- x11-base/xorg-proto
-"
-
-src_prepare() {
- default
-
- sed -i -e 's|LICENCE||g' Makefile || die
-
- append-cflags -std=gnu89
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" NO_DEBUG=1
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- docdir=/usr/share/doc/${PF} \
- mandir=/usr/share/man \
- prefix=/usr \
- install
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/syntax
- doins etc/xnots.vim
- fi
-}