summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch')
-rw-r--r--x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch b/x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch
new file mode 100644
index 000000000000..995b4ea89608
--- /dev/null
+++ b/x11-misc/xscreensaver/files/xscreensaver-5.20-tests-miscfix.patch
@@ -0,0 +1,23 @@
+http://pkgs.fedoraproject.org/cgit/xscreensaver.git/tree/xscreensaver-5.12-tests-miscfix.patch
+
+--- driver/test-xdpms.c
++++ driver/test-xdpms.c
+@@ -29,7 +29,6 @@
+
+ #include <X11/Xproto.h>
+ #include <X11/extensions/dpms.h>
+-#include <X11/extensions/dpmsstr.h>
+
+ extern Bool DPMSQueryExtension (Display *dpy, int *event_ret, int *error_ret);
+ extern Bool DPMSCapable (Display *dpy);
+--- driver/Makefile.in
++++ driver/Makefile.in
+@@ -850,7 +850,7 @@
+ test-mlstring: test-mlstring.o
+ $(CC) -DTEST $(LDFLAGS) -o $@ test-mlstring.o $(SAVER_LIBS)
+
+-TEST_FADE_OBJS = test-fade.o $(UTILS_SRC)/fade.o $(DEMO_UTIL_OBJS)
++TEST_FADE_OBJS = test-fade.o $(UTILS_BIN)/fade.o $(DEMO_UTIL_OBJS)
+ test-fade: test-fade.o $(UTILS_BIN)/fade.o
+ $(CC) $(LDFLAGS) -o $@ $(TEST_FADE_OBJS) $(SAVER_LIBS)
+