summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsel/xsel-1.2.0-r2.ebuild')
-rw-r--r--x11-misc/xsel/xsel-1.2.0-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/xsel/xsel-1.2.0-r2.ebuild b/x11-misc/xsel/xsel-1.2.0-r2.ebuild
new file mode 100644
index 000000000000..3f2c213b8b7e
--- /dev/null
+++ b/x11-misc/xsel/xsel-1.2.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Command-line program for getting and setting the contents of the X selection"
+HOMEPAGE="https://www.vergenet.net/~conrad/software/xsel"
+SRC_URI="https://www.vergenet.net/~conrad/software/${PN}/download/${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libXt"
+
+PATCHES=( "${FILESDIR}"/${P}-Werror.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}