summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsel/xsel-1.2.1.ebuild')
-rw-r--r--x11-misc/xsel/xsel-1.2.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/xsel/xsel-1.2.1.ebuild b/x11-misc/xsel/xsel-1.2.1.ebuild
new file mode 100644
index 000000000000..e7570554b3ad
--- /dev/null
+++ b/x11-misc/xsel/xsel-1.2.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Command-line program for getting and setting the contents of the X selection"
+HOMEPAGE="https://vergenet.net/~conrad/software/xsel"
+SRC_URI="https://github.com/kfish/xsel/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
+
+DEPEND="x11-libs/libX11"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}