summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsensors/xsensors-0.70.ebuild')
-rw-r--r--x11-misc/xsensors/xsensors-0.70.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/xsensors/xsensors-0.70.ebuild b/x11-misc/xsensors/xsensors-0.70.ebuild
new file mode 100644
index 000000000000..badf480b1fb2
--- /dev/null
+++ b/x11-misc/xsensors/xsensors-0.70.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="A hardware health information viewer, interface to lm-sensors"
+HOMEPAGE="http://www.linuxhardware.org/xsensors/"
+SRC_URI="http://www.linuxhardware.org/xsensors/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=sys-apps/lm_sensors-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk220.patch
+
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ -e 's:-Werror:-Wall:' \
+ src/Makefile.am configure.in || die
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+}