summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xssstate/xssstate-1.1.ebuild')
-rw-r--r--x11-misc/xssstate/xssstate-1.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/xssstate/xssstate-1.1.ebuild b/x11-misc/xssstate/xssstate-1.1.ebuild
new file mode 100644
index 000000000000..460229ec0b2e
--- /dev/null
+++ b/x11-misc/xssstate/xssstate-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A simple tool to retrieve the X screensaver state"
+HOMEPAGE="http://tools.suckless.org/xssstate"
+SRC_URI="http://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXScrnSaver
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/scrnsaverproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.20130103-gentoo.patch
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX='/usr' install
+ dodoc README xsidle.sh
+ doman ${PN}.1
+}