summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/asapm/files/asapm-3.1-ldflags.patch')
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-ldflags.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/x11-plugins/asapm/files/asapm-3.1-ldflags.patch b/x11-plugins/asapm/files/asapm-3.1-ldflags.patch
new file mode 100644
index 000000000000..a90d7baf2e4e
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- a/autoconf/Makefile.common.in
++++ b/autoconf/Makefile.common.in
+@@ -34,7 +34,7 @@
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(LDFLAGS) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c