summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild')
-rw-r--r--x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild b/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild
index 196a466da0e0..ba410ab76f8e 100644
--- a/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild
+++ b/x11-plugins/bubblemon/bubblemon-1.46-r3.ebuild
@@ -1,30 +1,31 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="A fun monitoring applet for your desktop, complete with swimming duck"
HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${PN}-dockapp-${PV}.tar.gz"
+S="${WORKDIR}"/${PN}-dockapp-${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc ~sparc x86 ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE=""
RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${PN}-dockapp-${PV}
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
-PATCHES=( "${FILESDIR}"/${P}-gtk.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-gtk.patch
"${FILESDIR}"/${P}-asneeded.patch
- "${FILESDIR}"/${P}-no_display.patch )
+ "${FILESDIR}"/${P}-no_display.patch
+)
src_compile() {
- tc-export CC
+ tc-export CC PKG_CONFIG
emake GENTOO_CFLAGS="${CFLAGS}"
}