summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmMatrix')
-rw-r--r--x11-plugins/wmMatrix/files/wmMatrix-0.2-fno-common.patch37
-rw-r--r--x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild7
2 files changed, 42 insertions, 2 deletions
diff --git a/x11-plugins/wmMatrix/files/wmMatrix-0.2-fno-common.patch b/x11-plugins/wmMatrix/files/wmMatrix-0.2-fno-common.patch
new file mode 100644
index 000000000000..1bb92d66a6c2
--- /dev/null
+++ b/x11-plugins/wmMatrix/files/wmMatrix-0.2-fno-common.patch
@@ -0,0 +1,37 @@
+--- a/xutils.h
++++ b/xutils.h
+@@ -18,11 +18,11 @@
+ /*
+ * Global variable
+ */
+-Display *display;
+-Window Root;
+-Window iconwin, win;
+-int screen;
+-int DisplayDepth;
++extern Display *display;
++extern Window Root;
++extern Window iconwin, win;
++extern int screen;
++extern int DisplayDepth;
+
+
+
+--- a/xutils.c
++++ b/xutils.c
+@@ -42,6 +42,15 @@
+ #include "xutils.h"
+
+
++/*
++ * Global variable
++ */
++Display *display;
++Window Root;
++Window iconwin, win;
++int screen;
++int DisplayDepth;
++
+
+ /*
+ * X11 Variables
diff --git a/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild b/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild
index e66928258312..5b686f451ee5 100644
--- a/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild
+++ b/x11-plugins/wmMatrix/wmMatrix-0.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,7 +22,10 @@ LICENSE="GPL-2"
KEYWORDS="amd64 ppc ppc64 ~sparc x86"
IUSE=""
-PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-fno-common.patch
+ )
src_compile() {
# this version is distributed with compiled binaries!