summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmSun/wmSun-1.05.ebuild')
-rw-r--r--x11-plugins/wmSun/wmSun-1.05.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmSun/wmSun-1.05.ebuild b/x11-plugins/wmSun/wmSun-1.05.ebuild
new file mode 100644
index 000000000000..b84ab08da695
--- /dev/null
+++ b/x11-plugins/wmSun/wmSun-1.05.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+MY_P=${P/S/s}
+DESCRIPTION="dockapp which displays the rise/set time of the sun"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmsun"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README {BUGS,TODO}
+}