summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild')
-rw-r--r--x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild b/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild
new file mode 100644
index 000000000000..9ac2df6c71d8
--- /dev/null
+++ b/x11-plugins/wmcliphist/wmcliphist-0.6-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dockable clipboard history application for Window Maker"
+HOMEPAGE="http://linux.nawebu.cz/wmcliphist"
+SRC_URI="http://linux.nawebu.cz/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-fix-docking.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ChangeLog README
+ newdoc .${PN}rc ${PN}rc.sample
+}