summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmdiskmon')
-rw-r--r--x11-plugins/wmdiskmon/Manifest2
-rw-r--r--x11-plugins/wmdiskmon/metadata.xml5
-rw-r--r--x11-plugins/wmdiskmon/wmdiskmon-0.0.1.ebuild24
-rw-r--r--x11-plugins/wmdiskmon/wmdiskmon-0.0.2.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/wmdiskmon/Manifest b/x11-plugins/wmdiskmon/Manifest
new file mode 100644
index 000000000000..3304146f8638
--- /dev/null
+++ b/x11-plugins/wmdiskmon/Manifest
@@ -0,0 +1,2 @@
+DIST wmdiskmon-0.0.1.tar.gz 91956 SHA256 7b856e6a8fd8f1aa8e3b698e28e8abd82700a8101e7a5c36f5bcd80b275f57ce
+DIST wmdiskmon-0.0.2.tar.gz 91996 SHA256 7f785aa2575c980bb2732fd69d53daeab6b2047b9e5dc3548d909145779fe06e SHA512 c39c298961129fc6951d27096c2993b0cafcba52b5898518fdb6f446b6fd6332db1df36bd1c812f1b1ab7fb0c59759f749176a675a29eb271a72430709ef550b WHIRLPOOL 32d797bce1c584fdf7b5a9687445139050a36c7698d516fbd940bd22966cdab9636ff20a77060cb4b06534632cba552c259d5b794003491c24528e242be399dd
diff --git a/x11-plugins/wmdiskmon/metadata.xml b/x11-plugins/wmdiskmon/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmdiskmon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmdiskmon/wmdiskmon-0.0.1.ebuild b/x11-plugins/wmdiskmon/wmdiskmon-0.0.1.ebuild
new file mode 100644
index 000000000000..991f1a13dcc9
--- /dev/null
+++ b/x11-plugins/wmdiskmon/wmdiskmon-0.0.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="a dockapp to display disk space usage"
+HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
+SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog THANKS TODO
+}
diff --git a/x11-plugins/wmdiskmon/wmdiskmon-0.0.2.ebuild b/x11-plugins/wmdiskmon/wmdiskmon-0.0.2.ebuild
new file mode 100644
index 000000000000..7a28208a963d
--- /dev/null
+++ b/x11-plugins/wmdiskmon/wmdiskmon-0.0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+DESCRIPTION="a dockapp to display disk space usage"
+HOMEPAGE="http://tnemeth.free.fr/projets/dockapps.html"
+SRC_URI="http://tnemeth.free.fr/projets/programmes/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog THANKS TODO
+}