summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild')
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
new file mode 100644
index 000000000000..b373fb396389
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gtk.patch \
+ "${FILESDIR}"/${P}-no_display.patch
+
+ sed -i -e "s/\$(CC)/& \$(LDFLAGS)/" Makefile || die #331891
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README
+}