summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmfsm/wmfsm-0.35.ebuild')
-rw-r--r--x11-plugins/wmfsm/wmfsm-0.35.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/wmfsm/wmfsm-0.35.ebuild b/x11-plugins/wmfsm/wmfsm-0.35.ebuild
new file mode 100644
index 000000000000..e4238097321a
--- /dev/null
+++ b/x11-plugins/wmfsm/wmfsm-0.35.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+IUSE=""
+DESCRIPTION="dockapp for monitoring filesystem usage"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmfsm"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="http://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/dockapps
+
+src_prepare() {
+ sed -e "/^X11LIBS/s/-I$x_includes //" -i configure.ac || die "sed failed"
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog
+}