summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmitime/wmitime-0.3.ebuild')
-rw-r--r--x11-plugins/wmitime/wmitime-0.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/wmitime/wmitime-0.3.ebuild b/x11-plugins/wmitime/wmitime-0.3.ebuild
new file mode 100644
index 000000000000..5c3b3814c763
--- /dev/null
+++ b/x11-plugins/wmitime/wmitime-0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+S=${WORKDIR}/${PN}
+IUSE=""
+DESCRIPTION="Overglorified clock dockapp w/time, date, and internet time"
+HOMEPAGE="http://www.neotokyo.org/illusion/"
+SRC_URI="http://www.neotokyo.org/illusion/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/makefile.diff
+}
+
+src_compile() {
+ cd "${S}"/wmitime
+ make || die "make failed"
+}
+
+src_install() {
+ cd "${S}"/wmitime
+ dobin wmitime
+
+ cd "${S}"
+ dodoc BUGS CHANGES README
+}