summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmlife')
-rw-r--r--x11-plugins/wmlife/Manifest1
-rw-r--r--x11-plugins/wmlife/files/wmlife-1.0.0-stringh.patch11
-rw-r--r--x11-plugins/wmlife/files/wmlife-1.0.1-configure.patch11
-rw-r--r--x11-plugins/wmlife/metadata.xml5
-rw-r--r--x11-plugins/wmlife/wmlife-1.0.1.ebuild39
5 files changed, 67 insertions, 0 deletions
diff --git a/x11-plugins/wmlife/Manifest b/x11-plugins/wmlife/Manifest
new file mode 100644
index 000000000000..def9f1ad9a83
--- /dev/null
+++ b/x11-plugins/wmlife/Manifest
@@ -0,0 +1 @@
+DIST wmlife-1.0.1.tar.gz 92142 SHA256 4db33af31f661e1057d809413f679860bfb6e1d03d064f89792e84d1054ef8a1 SHA512 07cf6428e4d103e203b2e228e35bea13fe580de674d0ea61ab227e5e9bbc406495dbe0f2b7d6647b5d48930cc2d4c3fc097da115995619fdf25a7367b4fd9e84 WHIRLPOOL 60ce082fc2da0a413986ff553ba01f16cc78d8b807fbdc2e41d99292ecfa51bdd32eb9e8c94337bae85622fc541f339d781ce0b6d20145c5c89cb3ff100e1133
diff --git a/x11-plugins/wmlife/files/wmlife-1.0.0-stringh.patch b/x11-plugins/wmlife/files/wmlife-1.0.0-stringh.patch
new file mode 100644
index 000000000000..8994827d63eb
--- /dev/null
+++ b/x11-plugins/wmlife/files/wmlife-1.0.0-stringh.patch
@@ -0,0 +1,11 @@
+diff -ur wmlife-1.0.0.orig/src/session.c wmlife-1.0.0/src/session.c
+--- wmlife-1.0.0.orig/src/session.c 2005-09-23 00:18:09.000000000 +0300
++++ wmlife-1.0.0/src/session.c 2008-01-12 14:39:52.000000000 +0200
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>
++#include <string.h>
+ #include <sys/types.h>
+ #include <pwd.h>
+
diff --git a/x11-plugins/wmlife/files/wmlife-1.0.1-configure.patch b/x11-plugins/wmlife/files/wmlife-1.0.1-configure.patch
new file mode 100644
index 000000000000..35ba4029554f
--- /dev/null
+++ b/x11-plugins/wmlife/files/wmlife-1.0.1-configure.patch
@@ -0,0 +1,11 @@
+diff -Naur wmlife-1.0.0-orig/configure.in wmlife-1.0.0/configure.in
+--- wmlife-1.0.0-orig/configure.in 2005-09-23 00:18:09.000000000 +0300
++++ wmlife-1.0.0/configure.in 2014-04-28 23:52:09.701103219 +0300
+@@ -38,6 +38,6 @@
+ AC_CACHE_CHECK([for gdk2 libs], GDKLIBS, [GDKLIBS=`$config --libs gtk+-2.0 | sed -e "s/-lgtk-x11-2.0//g" -e "s/-latk-1.0//g"`])
+
+ CFLAGS="$CFLAGS $GDKINCS"
+-LDFLAGS="$LDFLAGS $GDKLIBS"
++LDFLAGS="$LDFLAGS $GDKLIBS -lm"
+
+ AC_OUTPUT(Makefile src/Makefile)
diff --git a/x11-plugins/wmlife/metadata.xml b/x11-plugins/wmlife/metadata.xml
new file mode 100644
index 000000000000..b1a9efc4f2f0
--- /dev/null
+++ b/x11-plugins/wmlife/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+</pkgmetadata>
diff --git a/x11-plugins/wmlife/wmlife-1.0.1.ebuild b/x11-plugins/wmlife/wmlife-1.0.1.ebuild
new file mode 100644
index 000000000000..82e9986d3f04
--- /dev/null
+++ b/x11-plugins/wmlife/wmlife-1.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="dockapp running Conway's Game of Life (and program launcher)"
+HOMEPAGE="http://www.swanson.ukfsn.org/#wmlife"
+SRC_URI="http://www.swanson.ukfsn.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext"
+EPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.0.0-stringh.patch
+ "${FILESDIR}"/${P}-configure.patch )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.0-stringh.patch
+ epatch "${FILESDIR}"/${P}-configure.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --enable-session
+}