summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmmisc/wmmisc-1.1.ebuild')
-rw-r--r--x11-plugins/wmmisc/wmmisc-1.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmmisc/wmmisc-1.1.ebuild b/x11-plugins/wmmisc/wmmisc-1.1.ebuild
new file mode 100644
index 000000000000..aeaeeee02bac
--- /dev/null
+++ b/x11-plugins/wmmisc/wmmisc-1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a monitoring dockapp for system load, user amount, fork amount and processes"
+HOMEPAGE="http://packages.qa.debian.org/w/wmmisc.html"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${P}/src
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ../{ChangeLog,README}
+}