summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmnet/wmnet-1.06-r1.ebuild')
-rw-r--r--x11-plugins/wmnet/wmnet-1.06-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/wmnet/wmnet-1.06-r1.ebuild b/x11-plugins/wmnet/wmnet-1.06-r1.ebuild
new file mode 100644
index 000000000000..31eaaa35b1c2
--- /dev/null
+++ b/x11-plugins/wmnet/wmnet-1.06-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE=""
+DESCRIPTION="WMnet is a dock.app network monitor"
+SRC_URI="http://www.digitalkaos.net/linux/wmnet/download/${P}.tar.gz
+ mirror://gentoo/${P}-misc.patch.bz2"
+HOMEPAGE="http://www.digitalkaos.net/linux/wmnet/"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-misc/imake
+ app-text/rman"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc alpha amd64 ppc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P}-misc.patch # bug 72818
+}
+
+src_compile() {
+ xmkmf || die "xmkmf failed."
+ emake CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ dobin wmnet
+ newman wmnet.man wmnet.1
+ dodoc README Changelog
+}