summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmswallow')
-rw-r--r--x11-plugins/wmswallow/Manifest1
-rw-r--r--x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch16
-rw-r--r--x11-plugins/wmswallow/metadata.xml12
-rw-r--r--x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild38
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-plugins/wmswallow/Manifest b/x11-plugins/wmswallow/Manifest
new file mode 100644
index 000000000000..052711d1b902
--- /dev/null
+++ b/x11-plugins/wmswallow/Manifest
@@ -0,0 +1 @@
+DIST wmswallow.tar.Z 28567 SHA256 7d7a3dc64b89eeb388bb2f66815fc94cb551d0899f0e41d204f367109a2cda02 SHA512 24ef61a4084bda49afd6a7168600d99c60fe85daab6d16733fd208a905966433ca3d031a1d991676f3e73cb8a3a552c49fe69cfb4e1271e7c9a09d9247c21cdc WHIRLPOOL 1d6d6e19075b9a8daba03f99ef04357fc48bdb71e2373386f29a2636611ae20b56398b1871c8b163d069fbb4ee07c98cf1b27fd6bd5178a7756a011cd4d44be8
diff --git a/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch b/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch
new file mode 100644
index 000000000000..7a2fe4cf1f36
--- /dev/null
+++ b/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch
@@ -0,0 +1,16 @@
+--- wmswallow.c.orig 2015-04-01 17:12:29.420177608 +0200
++++ wmswallow.c 2015-04-01 17:13:14.947182921 +0200
+@@ -445,11 +445,11 @@
+ int printlist(FILE * stream, char * string, char **stringlist) {
+ int i=0;
+
+- fprintf(stream, string);
++ fprintf(stream, "%s", string);
+ if (stringlist!=NULL) {
+ while (stringlist[i]!=NULL) {
+ fprintf(stream, " §");
+- fprintf(stream, stringlist[i]);
++ fprintf(stream, "%s", stringlist[i]);
+ fprintf(stream, "§ ");
+ ++i;
+ }
diff --git a/x11-plugins/wmswallow/metadata.xml b/x11-plugins/wmswallow/metadata.xml
new file mode 100644
index 000000000000..50d126d55f8d
--- /dev/null
+++ b/x11-plugins/wmswallow/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<longdescription>
+wmswallow is a WindowMaker dock applet that makes any application dockable. You
+can define an action to be taken on a mouseclick if the window does not receive
+mouseclicks itself, and you can define the size and width of the swallowed
+window on the commandline. Applications may be started on the commandline and
+specified via name, class, or window-id.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..8d30dab5d06e
--- /dev/null
+++ b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A dock applet to make any application dockable"
+HOMEPAGE="http://burse.uni-hamburg.de/~friedel/software/wmswallow.html"
+SRC_URI="http://burse.uni-hamburg.de/~friedel/software/wmswallow/${PN}.tar.Z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/wmswallow
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+ sed -e "s:\${OBJS} -o:\${OBJS} \${LDFLAGS} -o:" \
+ -e "/LIBS/s/-lXext/-lX11 \0/"\
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" xfree
+}
+
+src_install() {
+ dobin wmswallow
+ dodoc CHANGELOG README todo
+}