summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmudmount/Manifest1
-rw-r--r--x11-plugins/wmudmount/metadata.xml4
-rw-r--r--x11-plugins/wmudmount/wmudmount-3.0.ebuild42
3 files changed, 47 insertions, 0 deletions
diff --git a/x11-plugins/wmudmount/Manifest b/x11-plugins/wmudmount/Manifest
index fd46afa9be1a..9949c6db3059 100644
--- a/x11-plugins/wmudmount/Manifest
+++ b/x11-plugins/wmudmount/Manifest
@@ -1 +1,2 @@
DIST wmudmount-2.2.tar.gz 181700 BLAKE2B f375aca9da44b5cba1483b70c36bbed81d897a691ce91ca5d3e11f8bbbbe1cc46685480d41144d6cca0bd10f625e46b5eec2ffc573ec7dd90b9b241dde7605a2 SHA512 6bc08b60430bbe66710ce183f0e7693a7818cee68cefac3a3bc191104663dd3649f8cdb62c7f214bdf4ed377b01fef250fe388f14645690aab7993c6071ceffe
+DIST wmudmount-3.0.tar.gz 189435 BLAKE2B e04c0bedfd4d0f4deed88f3acc87e4f2871890d6d12811404ec6c884107ae6bd9df17e724100068b08ff31ae557a02cd20bfc86222111939984fcc7916466c06 SHA512 dd12354d281ab04255e4ecf600d05c661168ed69b48439bba4ee6e61f2c93507e35e45c6f6671426c26df2fcf17ba5e851a6a3a3d757a5016a49bd8f76893eb9
diff --git a/x11-plugins/wmudmount/metadata.xml b/x11-plugins/wmudmount/metadata.xml
index f78dad9d13a3..658d5857f5dc 100644
--- a/x11-plugins/wmudmount/metadata.xml
+++ b/x11-plugins/wmudmount/metadata.xml
@@ -5,6 +5,10 @@
<email>voyageur@gentoo.org</email>
<name>Bernard Cafarelli</name>
</maintainer>
+ <use>
+ <flag name="gcr">Enable support for secure memory with <pkg>app-crypt/gcr</pkg></flag>
+ <flag name="secret">Enable support for secret service with <pkg>app-crypt/libsecret</pkg></flag>
+ </use>
<upstream>
<remote-id type="sourceforge">wmudmount</remote-id>
</upstream>
diff --git a/x11-plugins/wmudmount/wmudmount-3.0.ebuild b/x11-plugins/wmudmount/wmudmount-3.0.ebuild
new file mode 100644
index 000000000000..9b83e5ecdee5
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="https://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gcr libnotify secret"
+
+RDEPEND="sys-fs/udisks:2
+ >=x11-libs/gtk+-3.16.0:3
+ gcr? ( app-crypt/gcr )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ secret? ( app-crypt/libsecret )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ virtual/imagemagick-tools[png]"
+
+DOCS="ChangeLog"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.2-perl_brace_regex.patch )
+
+src_configure() {
+ econf \
+ $(use_with gcr) \
+ $(use_with libnotify) \
+ $(use_with secret)
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}