summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/qterminal/qterminal-0.6.0.ebuild')
-rw-r--r--x11-terms/qterminal/qterminal-0.6.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-terms/qterminal/qterminal-0.6.0.ebuild b/x11-terms/qterminal/qterminal-0.6.0.ebuild
new file mode 100644
index 000000000000..b2354fb6c684
--- /dev/null
+++ b/x11-terms/qterminal/qterminal-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://github.com/qterminal/qterminal"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug qt4 qt5"
+
+REQUIRED_USE="^^ ( qt4 qt5 )"
+
+DEPEND="
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-libs/libqxt
+ ~x11-libs/qtermwidget-${PV}[qt4(+)]
+ )
+ qt5? (
+ dev-qt/linguist-tools:5
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ ~x11-libs/qtermwidget-${PV}[qt5(-)]
+ )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_use qt5)
+ $(cmake-utils_use_use qt4 SYSTEM_QXT)
+ )
+ cmake-utils_src_configure
+}