summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/sakura/files')
-rw-r--r--x11-terms/sakura/files/sakura-3.1.3-flags.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/x11-terms/sakura/files/sakura-3.1.3-flags.patch b/x11-terms/sakura/files/sakura-3.1.3-flags.patch
new file mode 100644
index 000000000000..28b72dd694a6
--- /dev/null
+++ b/x11-terms/sakura/files/sakura-3.1.3-flags.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -35,12 +35,6 @@
+ ADD_DEFINITIONS (-DDATADIR=\\\"${CMAKE_INSTALL_PREFIX}/share\\\")
+ ADD_DEFINITIONS (-DBUILDTYPE=\\\"${CMAKE_BUILD_TYPE}\\\")
+
+-IF (${CMAKE_BUILD_TYPE} MATCHES "Debug")
+- SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
+-ELSE (${CMAKE_BUILD_TYPE} NOT MATCHES "Debug")
+- SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -O2 -Wno-deprecated-declarations")
+-ENDIF (${CMAKE_BUILD_TYPE} MATCHES "Debug")
+-
+ INCLUDE_DIRECTORIES (. ${GTK_INCLUDE_DIRS} ${VTE_INCLUDE_DIRS})
+ LINK_DIRECTORIES (${GTK_LIBRARY_DIRS} ${VTE_LIBRARY_DIRS})
+ LINK_LIBRARIES (${GTK_LIBRARIES} ${VTE_LIBRARIES} m)