summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/sakura/sakura-3.8.4.ebuild')
-rw-r--r--x11-terms/sakura/sakura-3.8.4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-terms/sakura/sakura-3.8.4.ebuild b/x11-terms/sakura/sakura-3.8.4.ebuild
new file mode 100644
index 000000000000..ffc114ff50bc
--- /dev/null
+++ b/x11-terms/sakura/sakura-3.8.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="GTK/VTE based terminal emulator"
+HOMEPAGE="https://www.pleyades.net/david/projects/sakura"
+SRC_URI="https://launchpad.net/sakura/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86 ~x86-linux"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3[X]
+ x11-libs/pango
+ x11-libs/vte:2.91"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libX11"
+BDEPEND="
+ sys-devel/gettext
+ virtual/perl-podlators"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ if [[ -v LINGUAS ]]; then
+ local lingua
+ for lingua in po/*.po; do
+ lingua=${lingua#*/}
+ lingua=${lingua%.*}
+ has ${lingua} ${LINGUAS} || rm po/${lingua}.po || die
+ done
+ fi
+}