summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/terminator/files')
-rw-r--r--x11-terms/terminator/files/0.90-without-icon-cache.patch11
-rw-r--r--x11-terms/terminator/files/0.93-session.patch13
-rw-r--r--x11-terms/terminator/files/0.94-session.patch13
-rw-r--r--x11-terms/terminator/files/terminator-0.97-brightness.patch35
4 files changed, 72 insertions, 0 deletions
diff --git a/x11-terms/terminator/files/0.90-without-icon-cache.patch b/x11-terms/terminator/files/0.90-without-icon-cache.patch
new file mode 100644
index 000000000000..c7862def3eaa
--- /dev/null
+++ b/x11-terms/terminator/files/0.90-without-icon-cache.patch
@@ -0,0 +1,11 @@
+--- setup.py.orig 2009-08-12 22:22:53.000000000 -0400
++++ setup.py 2009-08-12 22:22:57.000000000 -0400
+@@ -25,7 +25,7 @@
+
+ def __init__ (self, *args):
+ self.without_gettext = False
+- self.without_icon_cache = False
++ self.without_icon_cache = True
+ Distribution.__init__(self, *args)
+
+
diff --git a/x11-terms/terminator/files/0.93-session.patch b/x11-terms/terminator/files/0.93-session.patch
new file mode 100644
index 000000000000..c904a8ca494d
--- /dev/null
+++ b/x11-terms/terminator/files/0.93-session.patch
@@ -0,0 +1,13 @@
+diff --git a/terminatorlib/terminator.py b/terminatorlib/terminator.py
+index 34726cb..5adb7e7 100755
+--- a/terminatorlib/terminator.py
++++ b/terminatorlib/terminator.py
+@@ -60,8 +60,6 @@ class Terminator(Borg):
+ self.doing_layout = False
+ if not self.pid_cwd:
+ self.pid_cwd = get_pid_cwd()
+- if self.gnome_client is None:
+- self.attempt_gnome_client()
+
+ def attempt_gnome_client(self):
+ """Attempt to find a GNOME Session to register with"""
diff --git a/x11-terms/terminator/files/0.94-session.patch b/x11-terms/terminator/files/0.94-session.patch
new file mode 100644
index 000000000000..4583b0cff7b6
--- /dev/null
+++ b/x11-terms/terminator/files/0.94-session.patch
@@ -0,0 +1,13 @@
+diff --git a/terminatorlib/terminator.py b/terminatorlib/terminator.py
+index 1686006..960e53d 100755
+--- a/terminatorlib/terminator.py
++++ b/terminatorlib/terminator.py
+@@ -61,8 +61,6 @@ class Terminator(Borg):
+ self.doing_layout = False
+ if not self.pid_cwd:
+ self.pid_cwd = get_pid_cwd()
+- if self.gnome_client is None:
+- self.attempt_gnome_client()
+
+ def set_origcwd(self, cwd):
+ """Store the original cwd our process inherits"""
diff --git a/x11-terms/terminator/files/terminator-0.97-brightness.patch b/x11-terms/terminator/files/terminator-0.97-brightness.patch
new file mode 100644
index 000000000000..9e35d7d593f6
--- /dev/null
+++ b/x11-terms/terminator/files/terminator-0.97-brightness.patch
@@ -0,0 +1,35 @@
+=== modified file 'terminatorlib/prefseditor.py'
+--- terminatorlib/prefseditor.py 2013-02-16 00:10:45 +0000
++++ terminatorlib/prefseditor.py 2013-05-11 22:03:46 +0000
+@@ -923,6 +923,8 @@
+
+ def on_inactive_color_offset_change_value(self, widget, scroll, value):
+ """Inactive color offset setting changed"""
++ if value > 1.0:
++ value = 1.0
+ self.config['inactive_color_offset'] = round(value, 2)
+ self.config.save()
+
+
+=== modified file 'terminatorlib/terminal.py'
+--- terminatorlib/terminal.py 2013-02-15 15:10:55 +0000
++++ terminatorlib/terminal.py 2013-05-11 22:03:46 +0000
+@@ -621,11 +621,17 @@
+
+ factor = self.config['inactive_color_offset']
+ self.fgcolor_inactive = self.fgcolor_active.copy()
++ dbg(("fgcolor_inactive set to: RGB(%s,%s,%s)", getattr(self.fgcolor_inactive, "red"),
++ getattr(self.fgcolor_inactive, "green"),
++ getattr(self.fgcolor_inactive, "blue")))
+
+ for bit in ['red', 'green', 'blue']:
+ setattr(self.fgcolor_inactive, bit,
+ getattr(self.fgcolor_inactive, bit) * factor)
+
++ dbg(("fgcolor_inactive set to: RGB(%s,%s,%s)", getattr(self.fgcolor_inactive, "red"),
++ getattr(self.fgcolor_inactive, "green"),
++ getattr(self.fgcolor_inactive, "blue")))
+ colors = self.config['palette'].split(':')
+ self.palette_active = []
+ self.palette_inactive = []
+