summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/terminology/terminology-1.2.0.ebuild')
-rw-r--r--x11-terms/terminology/terminology-1.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-terms/terminology/terminology-1.2.0.ebuild b/x11-terms/terminology/terminology-1.2.0.ebuild
new file mode 100644
index 000000000000..30208be73e72
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/efl-1.20.0[eet,fontconfig,opengl,X]"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local emesonargs=(
+ -D nls=$(usex nls true false)
+ )
+
+ meson_src_configure
+}