summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/tilda')
-rw-r--r--x11-terms/tilda/Manifest1
-rw-r--r--x11-terms/tilda/files/tilda-0.9.6-gdk_resources.patch12
-rw-r--r--x11-terms/tilda/files/tilda-0.9.6-glib-single-include.patch13
-rw-r--r--x11-terms/tilda/metadata.xml10
-rw-r--r--x11-terms/tilda/tilda-0.9.6.ebuild28
5 files changed, 64 insertions, 0 deletions
diff --git a/x11-terms/tilda/Manifest b/x11-terms/tilda/Manifest
new file mode 100644
index 000000000000..8688c09e46ae
--- /dev/null
+++ b/x11-terms/tilda/Manifest
@@ -0,0 +1 @@
+DIST tilda-0.9.6.tar.gz 307517 SHA256 b3bd0f63eb83a5001ef26056ca116e5f8005d454f8f82a94f334868862068411 SHA512 7d0ddaf289de2c3f9f48f5cce3ee71534b9fdd91f79a4e56a32a301fd8fc82c4a3d760cfcd16d8d2e2d9f0d963b8130547720563ab15c2bb2220ff546ea562b0 WHIRLPOOL 1f3b25f508291b79872947441a981d1582bdbab57996f1e3673c1b575079fadaf6f39912f9e94cfc8559fead39615383c3515a3c4a8f6178e4a568ad7a67c088
diff --git a/x11-terms/tilda/files/tilda-0.9.6-gdk_resources.patch b/x11-terms/tilda/files/tilda-0.9.6-gdk_resources.patch
new file mode 100644
index 000000000000..a26ba91f5ec0
--- /dev/null
+++ b/x11-terms/tilda/files/tilda-0.9.6-gdk_resources.patch
@@ -0,0 +1,12 @@
+--- src/tilda_window.c 2008-01-17 23:07:39.000000000 +0100
++++ src/tilda_window.c 2010-03-19 22:30:31.000000000 +0100
+@@ -427,6 +427,9 @@
+ gtk_window_move (GTK_WINDOW(tw->window), config_getint ("x_pos"), config_getint ("y_pos"));
+ gtk_window_set_default_size (GTK_WINDOW(tw->window), config_getint ("max_width"), config_getint ("max_height"));
+ gtk_window_resize (GTK_WINDOW(tw->window), config_getint ("max_width"), config_getint ("max_height"));
++ /* Create GDK resources now, to prevent crashes later on */
++ gtk_widget_realize (tw->window);
++
+ generate_animation_positions (tw);
+
+ return tw;
diff --git a/x11-terms/tilda/files/tilda-0.9.6-glib-single-include.patch b/x11-terms/tilda/files/tilda-0.9.6-glib-single-include.patch
new file mode 100644
index 000000000000..fcc734f771d9
--- /dev/null
+++ b/x11-terms/tilda/files/tilda-0.9.6-glib-single-include.patch
@@ -0,0 +1,13 @@
+Index: tilda-0.9.6/src/tomboykeybinder.h
+===================================================================
+--- tilda-0.9.6.orig/src/tomboykeybinder.h
++++ tilda-0.9.6/src/tomboykeybinder.h
+@@ -2,7 +2,7 @@
+ #ifndef __TOMBOY_KEY_BINDER_H__
+ #define __TOMBOY_KEY_BINDER_H__
+
+-#include <glib/gtypes.h>
++#include <glib.h>
+
+ G_BEGIN_DECLS
+
diff --git a/x11-terms/tilda/metadata.xml b/x11-terms/tilda/metadata.xml
new file mode 100644
index 000000000000..d19d75f8fb73
--- /dev/null
+++ b/x11-terms/tilda/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>steev@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">tilda</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-terms/tilda/tilda-0.9.6.ebuild b/x11-terms/tilda/tilda-0.9.6.ebuild
new file mode 100644
index 000000000000..95d4582e39ec
--- /dev/null
+++ b/x11-terms/tilda/tilda-0.9.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="http://tilda.sourceforge.net"
+SRC_URI="mirror://sourceforge/tilda/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/vte:0
+ >=dev-libs/glib-2.8.4:2
+ dev-libs/confuse
+ gnome-base/libglade"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.9.6-gdk_resources.patch
+ epatch "${FILESDIR}"/${PN}-0.9.6-glib-single-include.patch
+}