summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch')
-rw-r--r--x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
new file mode 100644
index 000000000000..0075c433292b
--- /dev/null
+++ b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
@@ -0,0 +1,30 @@
+--- a/Makefile 2006-01-14 16:54:05.000000000 +0100
++++ b/Makefile 2009-02-26 16:18:25.000000000 +0100
+@@ -1,6 +1,4 @@
+ TARGET = yeahconsole
+-CC = gcc
+-#CC = cc
+ INSTALL = install
+
+ PREFIX = /usr/local
+@@ -8,17 +6,16 @@
+ LIBS = -lX11
+ INCLUDES = -I/usr/X11R6/include
+ LIB_DIRS = -L/usr/X11R6/lib
+-FLAGS = -Os -Wall
++FLAGS = -Wall $(CFLAGS)
+
+ OBJECTS := yeahconsole.o
+ SOURCES := yeahconsole.c
+
+ $(TARGET): $(OBJECTS)
+- $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
+- strip $@
++ $(CC) $(FLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -o $@ $< $(LIBS)
+
+ $(OBJECTS): $(SOURCES)
+- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
++ $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
+
+ clean:
+ rm -rf $(TARGET) $(OBJECTS)