summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/arc-icon-theme/arc-icon-theme-20160605.ebuild')
-rw-r--r--x11-themes/arc-icon-theme/arc-icon-theme-20160605.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/arc-icon-theme/arc-icon-theme-20160605.ebuild b/x11-themes/arc-icon-theme/arc-icon-theme-20160605.ebuild
new file mode 100644
index 000000000000..af889f706adb
--- /dev/null
+++ b/x11-themes/arc-icon-theme/arc-icon-theme-20160605.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools gnome2-utils
+
+DESCRIPTION="Vertex icon theme"
+HOMEPAGE="https://github.com/horst3180/arc-icon-theme"
+SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# Require adwaita until moka is packaged
+RDEPEND="
+ x11-themes/adwaita-icon-theme
+"
+DEPEND=""
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}