summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gnome-themes-standard')
-rw-r--r--x11-themes/gnome-themes-standard/Manifest1
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.20.2.ebuild83
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild45
3 files changed, 0 insertions, 129 deletions
diff --git a/x11-themes/gnome-themes-standard/Manifest b/x11-themes/gnome-themes-standard/Manifest
index f0b58acb87e9..3ffde6153871 100644
--- a/x11-themes/gnome-themes-standard/Manifest
+++ b/x11-themes/gnome-themes-standard/Manifest
@@ -1,3 +1,2 @@
DIST gnome-themes-standard-3.20.2.tar.xz 2878508 SHA256 9d0d9c4b2c9f9008301c3c1878ebb95859a735b7fd4a6a518802b9637e4a7915 SHA512 ce6dd2697e4afd5f36b6c362086eb5d5f3732ab863770f024e4970b2f7399b8ae6e49241de99bf8b558e4d80869ec1002d817f3dd9e7b8fbf9ea8da5a1d386fc WHIRLPOOL aa3e2f2f8a845cf6d1d09726cb58b113a8f4d6cf0cbf04b450602ba8ff17668dd827e0c2de40326f1a388d9a8998e03db4c301395a2e41ec3666e0c40cd23883
-DIST gnome-themes-standard-3.22.2.tar.xz 2900572 SHA256 b34516cd59b873c187c1897c25bac3b9ce2d30a472f1fd7ae9d7105d93e17da5 SHA512 d1fe6d93d06b9a231898055cf801adace0949c06658a08b445c3e0aaf127a4682d857463ee08a74d3652bad9e19bfaff4f651b5174cbeb76c99143da25cf39bd WHIRLPOOL 31c2e71d180b281d15319ca777a216d4db6be5639b4fb1ae33dbd1ff3981b4953ac934b58d1a77565c811d2c835f9d62518d342d8e5c1dc0a8ba5a8e437952aa
DIST gnome-themes-standard-3.22.3.tar.xz 2904736 SHA256 61dc87c52261cfd5b94d65e8ffd923ddeb5d3944562f84942eeeb197ab8ab56a SHA512 aa2f3ad4d867732cd09df6adb4f48ed2757e3f28930ef791ba97a82007332c810d84dd1074ca518ec0fe71bd7d8b95404854bd799e3b1fe616e1809e8ee33501 WHIRLPOOL cf45ce25f1fec524364c39aa8e367678e353c0f20443ec5bb380f187cf44d76fdb3c602b6c96a74f16a4ac479bf856e6fb84ddbb7a5b869e69d7734652db9613
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.20.2.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.20.2.ebuild
deleted file mode 100644
index cf95c59a7248..000000000000
--- a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.20.2.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-GNOME2_LA_PUNT="yes"
-
-inherit autotools eutils gnome2 multilib-minimal
-
-DESCRIPTION="Standard Themes for GNOME Applications"
-HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-IUSE="+gtk"
-KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
-
-COMMON_DEPEND="
- gnome-base/librsvg:2[${MULTILIB_USEDEP}]
- x11-libs/cairo[${MULTILIB_USEDEP}]
- gtk? (
- >=x11-libs/gtk+-2.24.15:2[${MULTILIB_USEDEP}]
- >=x11-libs/gtk+-3.12:3[${MULTILIB_USEDEP}] )
-"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
-"
-# gnome-themes{,-extras} are OBSOLETE for GNOME 3
-# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
-# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
-# their default background image
-RDEPEND="${COMMON_DEPEND}
- >=gnome-base/gsettings-desktop-schemas-3.4
- !<x11-themes/gnome-themes-2.32.1-r1
-"
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=746920
- eapply "${FILESDIR}/${PN}-3.14.2.3-srcdir.patch"
- eautoreconf
-
- gnome2_src_prepare
-}
-
-multilib_src_configure() {
- # The icon cache needs to be generated in pkg_postinst()
- ECONF_SOURCE="${S}" \
- gnome2_src_configure \
- --disable-static \
- $(use_enable gtk gtk2-engine) \
- $(use_enable gtk gtk3-engine) \
- GTK_UPDATE_ICON_CACHE=$(type -P true)
-}
-
-emake_engines_only() {
- pushd themes/Adwaita/gtk-2.0 > /dev/null || die
- if [[ $1 = install ]]; then
- emake DESTDIR="${D}" install-engineLTLIBRARIES
- else
- emake libadwaita.la
- fi
- popd > /dev/null
-}
-
-multilib_src_compile() {
- # processing >3500 icons is slow on old hard drives, do it only for native ABI
- if multilib_is_native_abi; then
- gnome2_src_compile
- elif use gtk; then
- emake_engines_only
- fi
-}
-
-multilib_src_install() {
- # processing >3500 icons is slow on old hard drives, do it only for native ABI
- if multilib_is_native_abi; then
- gnome2_src_install
- elif use gtk; then
- emake_engines_only install
- prune_libtool_files --modules
- fi
-}
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild
deleted file mode 100644
index 4cfd7c5694a2..000000000000
--- a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools gnome.org
-
-DESCRIPTION="Standard Themes for GNOME Applications"
-HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-IUSE=""
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
-
-# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
-# their default background image
-RDEPEND="
- >=gnome-base/gsettings-desktop-schemas-3.4
-"
-DEPEND="
- >=dev-util/intltool-0.40
- sys-devel/gettext
- virtual/pkgconfig
-"
-
-PATCHES=(
- # https://bugzilla.gnome.org/show_bug.cgi?id=746920
- "${FILESDIR}"/${PN}-3.14.2.3-srcdir.patch
- # Leave build of gtk+:2 engine to x11-themes/gtk-engines-adwaita
- "${FILESDIR}"/${PN}-3.22.2-exclude-engine.patch
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- ECONF_SOURCE="${S}" econf \
- --disable-static \
- --disable-gtk2-engine \
- --disable-gtk3-engine \
- GTK_UPDATE_ICON_CACHE=$(type -P true)
-}