summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/goddard-backgrounds/goddard-backgrounds-13.0.0.3.ebuild')
-rw-r--r--x11-themes/goddard-backgrounds/goddard-backgrounds-13.0.0.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-themes/goddard-backgrounds/goddard-backgrounds-13.0.0.3.ebuild b/x11-themes/goddard-backgrounds/goddard-backgrounds-13.0.0.3.ebuild
new file mode 100644
index 000000000000..f9843923916d
--- /dev/null
+++ b/x11-themes/goddard-backgrounds/goddard-backgrounds-13.0.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit versionator rpm
+
+SRC_PATH=development/15/source/SRPMS
+FEDORA=15
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F13_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CC-BY-SA-2.0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="!x11-themes/fedora-backgrounds:13"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+
+src_unpack() {
+ rpm_src_unpack
+
+ # as of 2010-06-21 rpm.eclass does not unpack the further lzma
+ # file automatically.
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ # The install targets are serial anyway.
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+}