summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-chtheme')
-rw-r--r--x11-themes/gtk-chtheme/Manifest1
-rw-r--r--x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-asneeded.patch24
-rw-r--r--x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-implicit.patch12
-rw-r--r--x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-qgtkstyle.patch12
-rw-r--r--x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild39
-rw-r--r--x11-themes/gtk-chtheme/metadata.xml5
6 files changed, 93 insertions, 0 deletions
diff --git a/x11-themes/gtk-chtheme/Manifest b/x11-themes/gtk-chtheme/Manifest
new file mode 100644
index 000000000000..e78818ac0dad
--- /dev/null
+++ b/x11-themes/gtk-chtheme/Manifest
@@ -0,0 +1 @@
+DIST gtk-chtheme-0.3.1.tar.bz2 18205 RMD160 5d080e905fc5d60c085e8c46d9338ddad805f38c SHA1 dbea31f4092877e786fe040fae1374238fada94a SHA256 26f4b6dd60c220d20d612ca840b6beb18b59d139078be72c7b1efefc447df844
diff --git a/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-asneeded.patch b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-asneeded.patch
new file mode 100644
index 000000000000..8cceb98a7565
--- /dev/null
+++ b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-asneeded.patch
@@ -0,0 +1,24 @@
+# LDFLAGS is for linker flags, not libraries
+# Fixes issue with forced --as-needed
+#
+# https://bugs.gentoo.org/show_bug.cgi?id=248655
+--- a/Makefile 2009-02-26 00:43:54.000000000 +0100
++++ b/Makefile 2009-02-26 00:43:32.000000000 +0100
+@@ -2,7 +2,7 @@
+
+ CFLAGS := $(if $(RPM_OPT_FLAGS), $(RPM_OPT_FLAGS), $(CFLAGS))
+
+-LDFLAGS = $(shell pkg-config --libs gtk+-2.0)
++LIBS = $(shell pkg-config --libs gtk+-2.0)
+ CFLAGS += -Wall
+ CFLAGS += $(shell pkg-config --cflags gtk+-2.0) -DGTK_DISABLE_BROKEN
+ CFLAGS += -DPROJNAME='"$(PROJNAME)"' -DVERSION='"$(VERSION)"'
+@@ -17,7 +17,7 @@
+ all: $(EXENAME) $(EXENAME).1
+
+ $(EXENAME): $(addsuffix .o, $(SRC))
+- $(CC) $(LDFLAGS) $^ -o $@
++ $(CC) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ $(EXENAME).1: $(EXENAME).pod
+ pod2man $< | sed 's/^\.TH .*/.TH $(EXENAME) 1/' > $@
diff --git a/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-implicit.patch b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-implicit.patch
new file mode 100644
index 000000000000..7d9f18cc6b55
--- /dev/null
+++ b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-implicit.patch
@@ -0,0 +1,12 @@
+diff -aur gtk-chtheme-0.3.1-orig/Makefile gtk-chtheme-0.3.1/Makefile
+--- gtk-chtheme-0.3.1-orig/Makefile 2004-02-09 12:08:41.000000000 -0500
++++ gtk-chtheme-0.3.1/Makefile 2008-06-27 12:19:02.000000000 -0400
+@@ -4,7 +4,7 @@
+
+ LDFLAGS = $(shell pkg-config --libs gtk+-2.0)
+ CFLAGS += -Wall
+-CFLAGS += $(shell pkg-config --cflags gtk+-2.0) -DGTK_DISABLE_BROKEN -DGTK_DISABLE_DEPRECATED
++CFLAGS += $(shell pkg-config --cflags gtk+-2.0) -DGTK_DISABLE_BROKEN
+ CFLAGS += -DPROJNAME='"$(PROJNAME)"' -DVERSION='"$(VERSION)"'
+ CPPFLAGS =
+ CXXFLAGS =
diff --git a/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-qgtkstyle.patch b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-qgtkstyle.patch
new file mode 100644
index 000000000000..b6c2b7a03551
--- /dev/null
+++ b/x11-themes/gtk-chtheme/files/gtk-chtheme-0.3.1-qgtkstyle.patch
@@ -0,0 +1,12 @@
+# Make gtk-chtheme work with qgtkstyle
+# https://bugs.gentoo.org/show_bug.cgi?id=250504
+--- a/main.c 2004-02-09 06:33:28.000000000 +0200
++++ b/main.c 2008-12-10 12:47:42.000000000 +0200
+@@ -97,6 +97,7 @@
+ fprintf(gtkrc_fh, "gtk-font-name=\"%s\"\n\n", font);
+ }
+
++ fprintf(gtkrc_fh, "gtk-theme-name = \"%s\"\n\n", themename);
+ fprintf(gtkrc_fh, "include \"%s/.gtkrc.mine\"\n\n", getenv("HOME"));
+ fprintf(gtkrc_fh, "# -- THEME AUTO-WRITTEN DO NOT EDIT\n");
+ fclose(gtkrc_fh);
diff --git a/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..b4a711e4ed59
--- /dev/null
+++ b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GTK-2.0 Theme Switcher"
+HOMEPAGE="http://plasmasturm.org/programs/gtk-chtheme/"
+SRC_URI="http://plasmasturm.org/programs/gtk-chtheme/${P}.tar.bz2"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~x86-macos"
+LICENSE="GPL-2"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # QA: stop Makefile from stripping the binaries
+ sed -i -e "s:strip:true:" "${S}"/Makefile || die "sed failed"
+ epatch "${FILESDIR}"/${P}-implicit.patch
+
+ # Fix forced as-needed, bug #248655
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+
+ # Make it work with qgtkstyle, bug #250504
+ epatch "${FILESDIR}/${P}-qgtkstyle.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die "emake install failed"
+}
diff --git a/x11-themes/gtk-chtheme/metadata.xml b/x11-themes/gtk-chtheme/metadata.xml
new file mode 100644
index 000000000000..dad9001338dc
--- /dev/null
+++ b/x11-themes/gtk-chtheme/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+</pkgmetadata>