summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/haematite-xcursors/haematite-xcursors-1.0.ebuild')
-rw-r--r--x11-themes/haematite-xcursors/haematite-xcursors-1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/haematite-xcursors/haematite-xcursors-1.0.ebuild b/x11-themes/haematite-xcursors/haematite-xcursors-1.0.ebuild
new file mode 100644
index 000000000000..966d28f51223
--- /dev/null
+++ b/x11-themes/haematite-xcursors/haematite-xcursors-1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PN=${PN/-xcursors/}
+DESCRIPTION="A simple crispy dark-grey xcursor theme"
+HOMEPAGE="http://www.kde-look.org/content/show.php/Haematite?content=19594"
+SRC_URI="http://www.kde-look.org/CONTENT/content-files/19594-${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ insinto /usr/share/cursors/xorg-x11/${MY_PN}
+ doins -r ${MY_PN}/cursors || die "doins failed"
+}
+
+pkg_postinst() {
+ elog "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ elog "and add the following line:"
+ elog "Xcursor.theme: ${MY_PN}"
+ elog
+ elog "You can change the size by adding a line like:"
+ elog "Xcursor.size: 48"
+ elog
+ elog "Also, to globally use this set of mouse cursors edit the file:"
+ elog " /usr/share/cursors/xorg-x11/default/index.theme"
+ elog "and change the line:"
+ elog " Inherits=[current setting]"
+ elog "to"
+ elog " Inherits=${MY_PN}"
+ elog
+ elog "Note this will be overruled by a user's ~/.Xdefaults file."
+ elog
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+}