summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r1.ebuild')
-rw-r--r--x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r1.ebuild b/x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r1.ebuild
new file mode 100644
index 000000000000..47c89bca9dd9
--- /dev/null
+++ b/x11-themes/vdr-channel-logos/vdr-channel-logos-0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P=${PN#vdr-channel-}-${PV}
+
+DESCRIPTION="Logos for vdr-skin*"
+HOMEPAGE="http://www.vdrskins.org/"
+SRC_URI="http://www.vdrskins.org/vdrskins/albums/userpics/10138/${MY_P}.tar.gz"
+
+LICENSE="fairuse"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S=${WORKDIR}/logos
+
+RDEPEND="app-text/convmv"
+
+src_prepare() {
+
+ convmv --notest --replace -f iso-8859-1 -t utf-8 -r "${S}"/
+}
+
+src_install() {
+ insinto /usr/share/vdr/channel-logos
+ find -maxdepth 1 -name "*.xpm" -print0|xargs -0 cp -a --target="${D}/usr/share/vdr/channel-logos/"
+}