summaryrefslogtreecommitdiff
path: root/x11-wm/i3
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/i3')
-rw-r--r--x11-wm/i3/Manifest3
-rw-r--r--x11-wm/i3/files/i3-4.6-missing_include.patch15
-rw-r--r--x11-wm/i3/files/i3-4.7.2-cflags.patch16
-rw-r--r--x11-wm/i3/files/i3-4.7.2-parallel_make.patch45
-rw-r--r--x11-wm/i3/i3-4.10.3.ebuild73
-rw-r--r--x11-wm/i3/i3-4.8.ebuild73
-rw-r--r--x11-wm/i3/i3-4.9.1.ebuild73
-rw-r--r--x11-wm/i3/i3-9999.ebuild75
-rw-r--r--x11-wm/i3/metadata.xml16
9 files changed, 389 insertions, 0 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
new file mode 100644
index 000000000000..4425d538817f
--- /dev/null
+++ b/x11-wm/i3/Manifest
@@ -0,0 +1,3 @@
+DIST i3-4.10.3.tar.bz2 941295 SHA256 9290857bd5a4d1a792544d763bedd53104a683f3e721b5631811827a388107d3 SHA512 914456663158d04868fc15820e3ca3c12663f6af120d2e249b0e2930214808cf19d719acbef9aed2931a322973e92e0da85a2e1d72a135e5894e81f14f2889f1 WHIRLPOOL ddca44ea2a9aeae140df26945860279987690bc7bedcb4395da2c1d52593081934f7cb2d819ff2d575eca855c29078a4155363fe0b116853ce637b86a4700d9e
+DIST i3-4.8.tar.bz2 939690 SHA256 502c34290f239780bb40352191f0500e8f35d2446eddb573c67c27873d6a1b6b SHA512 fd6f92da857246119f1ae710b6c5168128fa2da5eae8308550b1b9c75879f060cac8246897333f3d67e18de36828a11dd12b4ccee9bd6cd6ad32e2b44c50b43e WHIRLPOOL 6c6288cb66ffdbf225df0dfcdc4f540cd36d7c8333a9f9d9c363cb6580d6a7c1ca0deb227a8f46ac907f2afc6e4e46efc448a51f0764a167bb9639956beae4ef
+DIST i3-4.9.1.tar.bz2 939630 SHA256 b70deff027c7d05276c9646e53faeeeccdde706370b9b337a633bed85b16dc43 SHA512 7a8f71dd944faae426a2239b8bf12ea1cfc83a95c49fcb64ded8321ef302f3277af7d2ecd84d99cef47aba73e5a1091f94e37e9ed2af78c4722ffee507477c90 WHIRLPOOL 15cd2722beaeef642815edd44ff189ff0d003fefbff71c067b94a65dadb55cd15dd1a142a37499fa55cc80424dbdc74cb979c8998d740addcc492eaf025e467f
diff --git a/x11-wm/i3/files/i3-4.6-missing_include.patch b/x11-wm/i3/files/i3-4.6-missing_include.patch
new file mode 100644
index 000000000000..77147d264e18
--- /dev/null
+++ b/x11-wm/i3/files/i3-4.6-missing_include.patch
@@ -0,0 +1,15 @@
+Include float.h for DBL_EPSILON
+
+https://bugs.gentoo.org/show_bug.cgi?id=480272
+
+Patch was written by Jeroen Roovers <jer@gentoo.org>
+--- a/src/handlers.c
++++ b/src/handlers.c
+@@ -13,6 +13,7 @@
+ #include "all.h"
+
+ #include <time.h>
++#include <float.h>
+ #include <sys/time.h>
+ #include <xcb/randr.h>
+ #include <X11/XKBlib.h>
diff --git a/x11-wm/i3/files/i3-4.7.2-cflags.patch b/x11-wm/i3/files/i3-4.7.2-cflags.patch
new file mode 100644
index 000000000000..ed9256f441df
--- /dev/null
+++ b/x11-wm/i3/files/i3-4.7.2-cflags.patch
@@ -0,0 +1,16 @@
+Respect CFLAGS in linking command
+
+https://bugs.gentoo.org/show_bug.cgi?id=508426
+
+Patch written by Julian Ospald <hasufell@gentoo.org>
+--- a/src/i3.mk
++++ b/src/i3.mk
+@@ -64,7 +64,7 @@ i3-config-parser.stamp: generate-command-parser.pl parser-specs/config.spec
+
+ i3: libi3.a $(i3_OBJECTS)
+ echo "[i3] Link i3"
+- $(CC) $(I3_LDFLAGS) $(LDFLAGS) -o $@ $(filter-out libi3.a,$^) $(LIBS) $(i3_LIBS)
++ $(CC) $(CFLAGS) $(I3_LDFLAGS) $(LDFLAGS) -o $@ $(filter-out libi3.a,$^) $(LIBS) $(i3_LIBS)
+
+ install-i3: i3
+ echo "[i3] Install"
diff --git a/x11-wm/i3/files/i3-4.7.2-parallel_make.patch b/x11-wm/i3/files/i3-4.7.2-parallel_make.patch
new file mode 100644
index 000000000000..8e6eee75a938
--- /dev/null
+++ b/x11-wm/i3/files/i3-4.7.2-parallel_make.patch
@@ -0,0 +1,45 @@
+Fix parallel build
+
+https://bugs.gentoo.org/show_bug.cgi?id=508304
+
+Patch written by Julian Ospald <hasufell@gentoo.org>
+
+--- a/src/i3.mk
++++ b/src/i3.mk
+@@ -1,4 +1,4 @@
+-ALL_TARGETS += i3
++ALL_TARGETS += i3 test-tools
+ INSTALL_TARGETS += install-i3
+ CLEAN_TARGETS += clean-i3
+
+@@ -36,20 +36,22 @@ src/%.o: src/%.c $(i3_HEADERS_DEP)
+ echo "[i3] CC $<"
+ $(CC) $(I3_CPPFLAGS) $(XCB_CPPFLAGS) $(CPPFLAGS) $(i3_CFLAGS) $(I3_CFLAGS) $(CFLAGS) $(PCH_FLAGS) -c -o $@ ${canonical_path}/$<
+
+-# This target compiles the command parser twice:
+-# Once with -DTEST_PARSER, creating a stand-alone executable used for tests,
+-# and once as an object file for i3.
++test-tools: src/test.commands_parser src/test.config_parser
++
++src/test.commands_parser: src/commands_parser.c $(i3_HEADERS_DEP) i3-command-parser.stamp libi3.a
++ echo "[i3] Link test.commands_parser"
++ $(CC) $(I3_CPPFLAGS) $(XCB_CPPFLAGS) $(CPPFLAGS) $(i3_CFLAGS) $(I3_CFLAGS) $(CFLAGS) $(I3_LDFLAGS) $(LDFLAGS) -DTEST_PARSER -g -o test.commands_parser $< $(LIBS) $(i3_LIBS)
++
++src/test.config_parser: src/config_parser.c $(i3_HEADERS_DEP) i3-config-parser.stamp libi3.a
++ echo "[i3] Link test.config_parser"
++ $(CC) $(I3_CPPFLAGS) $(XCB_CPPFLAGS) $(CPPFLAGS) $(i3_CFLAGS) $(I3_CFLAGS) $(CFLAGS) $(I3_LDFLAGS) $(LDFLAGS) -DTEST_PARSER -g -o test.config_parser $< $(LIBS) $(i3_LIBS)
++
+ src/commands_parser.o: src/commands_parser.c $(i3_HEADERS_DEP) i3-command-parser.stamp
+ echo "[i3] CC $<"
+- $(CC) $(I3_CPPFLAGS) $(XCB_CPPFLAGS) $(CPPFLAGS) $(i3_CFLAGS) $(I3_CFLAGS) $(CFLAGS) $(I3_LDFLAGS) $(LDFLAGS) -DTEST_PARSER -g -o test.commands_parser $< $(LIBS) $(i3_LIBS)
+ $(CC) $(I3_CPPFLAGS) $(XCB_CPPFLAGS) $(CPPFLAGS) $(i3_CFLAGS) $(I3_CFLAGS) $(CFLAGS) -c -o $@ ${canonical_path}/$<
+
+-# This target compiles the command parser twice:
+-# Once with -DTEST_PARSER, creating a stand-alone executable used for tests,
+-# and once as an object file for i3.
+ src/config_parser.o: src/config_parser.c $(i3_HEADERS_DEP) i3-config-parser.stamp
+ echo "[i3] CC $<"
+- $(CC) $(I3_CPPFLAGS) $(XCB_CPPFLAGS) $(CPPFLAGS) $(i3_CFLAGS) $(I3_CFLAGS) $(CFLAGS) $(I3_LDFLAGS) $(LDFLAGS) -DTEST_PARSER -g -o test.config_parser $< $(LIBS) $(i3_LIBS)
+ $(CC) $(I3_CPPFLAGS) $(XCB_CPPFLAGS) $(CPPFLAGS) $(i3_CFLAGS) $(I3_CFLAGS) $(CFLAGS) -c -o $@ ${canonical_path}/$<
+
+ i3-command-parser.stamp: generate-command-parser.pl parser-specs/commands.spec
diff --git a/x11-wm/i3/i3-4.10.3.ebuild b/x11-wm/i3/i3-4.10.3.ebuild
new file mode 100644
index 000000000000..37b6435ca87f
--- /dev/null
+++ b/x11-wm/i3/i3-4.10.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="http://i3wm.org/"
+SRC_URI="http://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+pango"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ >=dev-libs/yajl-2.0.3
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ pango? (
+ >=x11-libs/pango-1.30.0[X]
+ >=x11-libs/cairo-1.12.2[X,xcb]
+ )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+
+DOCS=( RELEASE-NOTES-${PV} )
+
+src_prepare() {
+ if ! use pango; then
+ sed -i common.mk -e '/PANGO/d' || die
+ fi
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ epatch_user #471716
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ dohtml -r docs/*
+ doman man/*.1
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3status"
+ einfo " x11-misc/i3lock"
+ einfo "Please refer to their description for additional info."
+}
diff --git a/x11-wm/i3/i3-4.8.ebuild b/x11-wm/i3/i3-4.8.ebuild
new file mode 100644
index 000000000000..e9a2786222d3
--- /dev/null
+++ b/x11-wm/i3/i3-4.8.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="http://i3wm.org/"
+SRC_URI="http://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="+pango"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ >=dev-libs/yajl-2.0.3
+ x11-libs/libxcb[xkb]
+ x11-libs/libX11
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ pango? (
+ >=x11-libs/pango-1.30.0[X]
+ >=x11-libs/cairo-1.12.2[X,xcb]
+ )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+
+DOCS=( RELEASE-NOTES-${PV} )
+
+src_prepare() {
+ if ! use pango; then
+ sed -i common.mk -e '/PANGO/d' || die
+ fi
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ epatch_user #471716
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ dohtml -r docs/*
+ doman man/*.1
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3status"
+ einfo " x11-misc/i3lock"
+ einfo "Please refer to their description for additional info."
+}
diff --git a/x11-wm/i3/i3-4.9.1.ebuild b/x11-wm/i3/i3-4.9.1.ebuild
new file mode 100644
index 000000000000..37b6435ca87f
--- /dev/null
+++ b/x11-wm/i3/i3-4.9.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="http://i3wm.org/"
+SRC_URI="http://i3wm.org/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+pango"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ >=dev-libs/yajl-2.0.3
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ pango? (
+ >=x11-libs/pango-1.30.0[X]
+ >=x11-libs/cairo-1.12.2[X,xcb]
+ )"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+
+DOCS=( RELEASE-NOTES-${PV} )
+
+src_prepare() {
+ if ! use pango; then
+ sed -i common.mk -e '/PANGO/d' || die
+ fi
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ epatch_user #471716
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ dohtml -r docs/*
+ doman man/*.1
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3status"
+ einfo " x11-misc/i3lock"
+ einfo "Please refer to their description for additional info."
+}
diff --git a/x11-wm/i3/i3-9999.ebuild b/x11-wm/i3/i3-9999.ebuild
new file mode 100644
index 000000000000..ff4b0c71a417
--- /dev/null
+++ b/x11-wm/i3/i3-9999.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs git-2
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="http://i3wm.org/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/i3/i3"
+EGIT_BRANCH="next"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="+pango"
+
+CDEPEND="dev-lang/perl
+ dev-libs/libev
+ dev-libs/libpcre
+ >=dev-libs/yajl-2.0.3
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ pango? (
+ >=x11-libs/pango-1.30.0[X]
+ >=x11-libs/cairo-1.12.2[X,xcb]
+ )"
+DEPEND="${CDEPEND}
+ app-text/asciidoc
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+
+src_prepare() {
+ if ! use pango; then
+ sed -i common.mk -e '/PANGO/d' || die
+ fi
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+
+ epatch_user #471716
+}
+
+src_compile() {
+ emake V=1 CC="$(tc-getCC)" AR="$(tc-getAR)"
+ emake mans
+}
+
+src_install() {
+ default
+ dohtml -r docs/*
+ doman man/*.1
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3status"
+ einfo " x11-misc/i3lock"
+ einfo "Please refer to their description for additional info."
+}
diff --git a/x11-wm/i3/metadata.xml b/x11-wm/i3/metadata.xml
new file mode 100644
index 000000000000..ea839bceb0e3
--- /dev/null
+++ b/x11-wm/i3/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ <description>Maintains the live ebuild.</description>
+ </maintainer>
+ <use>
+ <flag name="pango">Use <pkg>x11-libs/pango</pkg> to render text in order to support fonts which have more glyphs (e.g. Kanji). See RELEASE-NOTES for more information</flag>
+ </use>
+</pkgmetadata>