summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/matchbox-common')
-rw-r--r--x11-wm/matchbox-common/Manifest1
-rw-r--r--x11-wm/matchbox-common/files/MatchBox.desktop8
-rw-r--r--x11-wm/matchbox-common/files/add-media-category.patch37
-rw-r--r--x11-wm/matchbox-common/files/no-utilities-category.patch7
-rw-r--r--x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild43
-rw-r--r--x11-wm/matchbox-common/metadata.xml8
6 files changed, 104 insertions, 0 deletions
diff --git a/x11-wm/matchbox-common/Manifest b/x11-wm/matchbox-common/Manifest
new file mode 100644
index 000000000000..57c1233c37c9
--- /dev/null
+++ b/x11-wm/matchbox-common/Manifest
@@ -0,0 +1 @@
+DIST matchbox-common-0.9.1.tar.bz2 86365 SHA256 524995b9899cc10d04c7964fb88ff8a2199865ca97e8d4988abd8d6c2a286199
diff --git a/x11-wm/matchbox-common/files/MatchBox.desktop b/x11-wm/matchbox-common/files/MatchBox.desktop
new file mode 100644
index 000000000000..8428a245f780
--- /dev/null
+++ b/x11-wm/matchbox-common/files/MatchBox.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=MatchBox
+Comment=This session logs you into MatchBox
+Exec=matchbox-session
+TryExec=/usr/bin/matchbox-session
+# no icon yet, only the top three are currently used
+Icon=
+Type=Application
diff --git a/x11-wm/matchbox-common/files/add-media-category.patch b/x11-wm/matchbox-common/files/add-media-category.patch
new file mode 100644
index 000000000000..5c502b379728
--- /dev/null
+++ b/x11-wm/matchbox-common/files/add-media-category.patch
@@ -0,0 +1,37 @@
+diff -urN matchbox-common-0.9.1/data/vfolders-pda.orig/Makefile.am matchbox-common-0.9.1/data/vfolders-pda/Makefile.am
+--- matchbox-common-0.9.1/data/vfolders-pda.orig/Makefile.am 2004-12-01 12:22:30.000000000 +0100
++++ matchbox-common-0.9.1/data/vfolders-pda/Makefile.am 2006-02-16 21:32:57.000000000 +0100
+@@ -1,5 +1,6 @@
+ desktop_files = Applications.directory \
+ Games.directory \
++ Media.directory \
+ Other.directory \
+ Root.directory \
+ Settings.directory \
+@@ -11,4 +12,4 @@
+ vfolders_DATA = $(desktop_files)
+ endif
+
+-EXTRA_DIST = $(desktop_files)
+\ No newline at end of file
++EXTRA_DIST = $(desktop_files)
+diff -urN matchbox-common-0.9.1/data/vfolders-pda.orig/Media.directory matchbox-common-0.9.1/data/vfolders-pda/Media.directory
+--- matchbox-common-0.9.1/data/vfolders-pda.orig/Media.directory 1970-01-01 01:00:00.000000000 +0100
++++ matchbox-common-0.9.1/data/vfolders-pda/Media.directory 2006-02-16 21:16:29.000000000 +0100
+@@ -0,0 +1,8 @@
++[Desktop Entry]
++Name=Media
++Name[de]=Medien
++Comment=View media files
++Comment[de]=Programme zur Wiedergabe von audiovisuellen Medien
++Icon=mbfolder.png
++Type=Directory
++Match=AudioVideo;Graphics;Media;Viewer;
+diff -urN matchbox-common-0.9.1/data/vfolders-pda.orig/Root.order matchbox-common-0.9.1/data/vfolders-pda/Root.order
+--- matchbox-common-0.9.1/data/vfolders-pda.orig/Root.order 2006-02-16 20:51:36.000000000 +0100
++++ matchbox-common-0.9.1/data/vfolders-pda/Root.order 2006-02-16 20:53:23.000000000 +0100
+@@ -1,3 +1,4 @@
++Media
+ Games
+ Settings
+ Other
diff --git a/x11-wm/matchbox-common/files/no-utilities-category.patch b/x11-wm/matchbox-common/files/no-utilities-category.patch
new file mode 100644
index 000000000000..6801533ac3a0
--- /dev/null
+++ b/x11-wm/matchbox-common/files/no-utilities-category.patch
@@ -0,0 +1,7 @@
+--- matchbox-common-0.9.1.orig/data/vfolders-pda/Root.order 2006-02-03 22:26:55.000000000 +0100
++++ matchbox-common-0.9.1/data/vfolders-pda/Root.order 2006-02-03 22:32:08.000000000 +0100
+@@ -1,4 +1,3 @@
+-Utilities
+ Games
+ Settings
+ Other
diff --git a/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild b/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild
new file mode 100644
index 000000000000..234eca3a0234
--- /dev/null
+++ b/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils versionator
+
+DESCRIPTION="Common files used by matchbox-panel and matchbox-desktop packages"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~hppa ppc x86"
+IUSE="pda"
+
+RDEPEND=">=x11-libs/libmatchbox-1.1"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf $(use_enable pda pda-folders)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # Insert our Xsession
+ echo -e "#!/bin/sh\n\nmatchbox-session" > "${T}"/matchbox
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/matchbox
+
+ # Insert GDM/KDM xsession file
+ wm=matchbox make_session_desktop MatchBox matchbox-session
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/no-utilities-category.patch
+ epatch "${FILESDIR}"/add-media-category.patch
+}
diff --git a/x11-wm/matchbox-common/metadata.xml b/x11-wm/matchbox-common/metadata.xml
new file mode 100644
index 000000000000..ad51fb7f931f
--- /dev/null
+++ b/x11-wm/matchbox-common/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gpe</herd>
+<use>
+ <flag name='pda'>Support for pda folders</flag>
+</use>
+</pkgmetadata>