summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/qtile/qtile-0.5-r1.ebuild')
-rw-r--r--x11-wm/qtile/qtile-0.5-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/x11-wm/qtile/qtile-0.5-r1.ebuild b/x11-wm/qtile/qtile-0.5-r1.ebuild
deleted file mode 100644
index 7db2d3cd7963..000000000000
--- a/x11-wm/qtile/qtile-0.5-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1 vcs-snapshot virtualx
-
-DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
-HOMEPAGE="http://qtile.org/"
-SRC_URI="https://github.com/qtile/qtile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND=">=dev-python/pycairo-1.10.0-r4[xcb,${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- >=x11-libs/xpyb-1.3.1-r1[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/python-xlib[${PYTHON_USEDEP}]
- x11-base/xorg-server[kdrive]
- )"
-
-# tests fail due to xauth errors from python-xlib
-RESTRICT="test"
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- VIRTUALX_COMMAND="nosetests" virtualmake
-}
-
-python_install_all() {
- local DOCS=( CHANGELOG README.rst TODO.rst )
- distutils-r1_python_install_all
-
- use doc && dohtml -r docs/_build/html/*
-
- insinto /usr/share/xsessions
- doins resources/qtile.desktop
-
- exeinto /etc/X11/Sessions
- newexe "${FILESDIR}"/${PN}-session ${PN}
-}