summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xmonad/xmonad-0.13.ebuild')
-rw-r--r--x11-wm/xmonad/xmonad-0.13.ebuild78
1 files changed, 0 insertions, 78 deletions
diff --git a/x11-wm/xmonad/xmonad-0.13.ebuild b/x11-wm/xmonad/xmonad-0.13.ebuild
deleted file mode 100644
index 80e6c99b32d2..000000000000
--- a/x11-wm/xmonad/xmonad-0.13.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# ebuild generated by hackport 0.5.1.9999
-#hackport: flags: -generatemanpage,-testing,-profiling
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="A tiling window manager"
-HOMEPAGE="https://xmonad.org/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="+default-term"
-
-RDEPEND="dev-haskell/data-default:=[profile?]
- dev-haskell/extensible-exceptions:=[profile?]
- dev-haskell/mtl:=[profile?]
- dev-haskell/setlocale:=[profile?]
- >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
- >=dev-haskell/x11-1.8:=[profile?] <dev-haskell/x11-1.9:=[profile?]
- >=dev-lang/ghc-8.0.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.24.0.0
- test? ( >=dev-haskell/quickcheck-2 )
-"
-PDEPEND="default-term? ( x11-terms/xterm )
- x11-apps/xmessage
-"
-
-DOCS=( CONFIG README.md CHANGES.md )
-HTML_DOCS=( man/xmonad.1.html )
-
-src_configure() {
- haskell-cabal_src_configure \
- --flag=-generatemanpage \
- --flag=-profiling \
- --flag=-testing
-}
-
-src_install() {
- default
-
- cabal_src_install
-
- echo -e "#!/bin/sh\n/usr/bin/xmonad" > "${T}/${PN}"
- exeinto /etc/X11/Sessions
- doexe "${T}/${PN}"
-
- insinto /usr/share/xsessions
- doins "${FILESDIR}/${PN}.desktop"
-
- doman man/xmonad.1
-}
-
-pkg_postinst() {
- haskell-cabal_pkg_postinst
-
- elog "A sample ${SAMPLE_CONFIG} configuration file can be found here:"
- elog " /usr/share/${PF}/ghc-$(ghc-version)/man/xmonad.hs"
- elog "The parameters in this file are the defaults used by xmonad."
- elog "To customize xmonad, copy this file to:"
- elog " ~/.xmonad/${SAMPLE_CONFIG}"
- elog "After editing, use 'mod-q' to dynamically restart xmonad "
- elog "(where the 'mod' key defaults to 'Alt')."
- elog ""
- elog "Read the README or man page for more information, and to see "
- elog "other possible configurations go to:"
- elog " http://haskell.org/haskellwiki/Xmonad/Config_archive"
- elog "Please note that many of these configurations will require the "
- elog "x11-wm/xmonad-contrib package to be installed."
-}