summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch')
-rw-r--r--x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch b/x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch
new file mode 100644
index 000000000000..9c580a513557
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.13.1-ignore-gentoo-no-compile.patch
@@ -0,0 +1,11 @@
+--- xpra-0.13.1/setup.py
++++ xpra-0.13.1/setup.py
+@@ -395,7 +395,7 @@
+ #then expects to find the cython modules!? ie:
+ #python2.7 setup.py build -b build-2.7 install --no-compile --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
+ if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
+- return
++ pass
+ cython_version_check(min_version)
+ from Cython.Distutils import build_ext
+ ext_modules.append(extension)