summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xpra/files/xpra-4.2-no-service.patch')
-rw-r--r--x11-wm/xpra/files/xpra-4.2-no-service.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/x11-wm/xpra/files/xpra-4.2-no-service.patch b/x11-wm/xpra/files/xpra-4.2-no-service.patch
new file mode 100644
index 000000000000..dd85370968ba
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-4.2-no-service.patch
@@ -0,0 +1,19 @@
+Don't install the service files. Auto-detection is used to determine what files
+to install, and where, which can be unpredictable on Gentoo. The init.d script
+is also not suitable for Gentoo.
+
+diff --git a/setup.py b/setup.py
+index 1718b06a9..b24a5bd1e 100755
+--- a/setup.py
++++ b/setup.py
+@@ -139,8 +139,8 @@ from xpra.platform.features import LOCAL_SERVERS_SUPPORTED, SHADOW_SUPPORTED
+ shadow_ENABLED = SHADOW_SUPPORTED and DEFAULT
+ server_ENABLED = (LOCAL_SERVERS_SUPPORTED or shadow_ENABLED) and DEFAULT
+ rfb_ENABLED = server_ENABLED
+-service_ENABLED = LINUX and server_ENABLED
+-sd_listen_ENABLED = POSIX and pkg_config_ok("--exists", "libsystemd")
++service_ENABLED = False
++sd_listen_ENABLED = False
+ proxy_ENABLED = DEFAULT
+ client_ENABLED = DEFAULT
+ scripts_ENABLED = not WIN32