summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfdesktop/xfdesktop-4.14.2-r1.ebuild')
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.14.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/xfdesktop-4.14.2-r1.ebuild b/xfce-base/xfdesktop/xfdesktop-4.14.2-r1.ebuild
new file mode 100644
index 000000000000..36257356e8ca
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.14.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+RDEPEND=">=x11-libs/cairo-1.12
+ >=dev-libs/glib-2.42
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.14:3
+ x11-libs/libX11
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? ( >=xfce-base/thunar-1.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-memleak.patch
+)
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}