summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/thunar-archive-plugin')
-rw-r--r--xfce-extra/thunar-archive-plugin/Manifest2
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r3.ebuild43
2 files changed, 44 insertions, 1 deletions
diff --git a/xfce-extra/thunar-archive-plugin/Manifest b/xfce-extra/thunar-archive-plugin/Manifest
index ca50c6791581..329fd8af3672 100644
--- a/xfce-extra/thunar-archive-plugin/Manifest
+++ b/xfce-extra/thunar-archive-plugin/Manifest
@@ -1 +1 @@
-DIST thunar-archive-plugin-0.3.1.tar.bz2 329005 SHA256 9ad559b0c11308f6897ad56604e5a06dc8f369f649eb20120b2d3018ef5da54c SHA512 51157c2680b3fcc6b541d35fc2943a350a0354d7d5bbb5fbe8a9dcbbeaf4bf4f5fe62521b8e9a73254f70bbefc440357deade8181313da96270c280eb0464e68 WHIRLPOOL 151a505968b871eae82bff1799464e4c6042e99668ec4752ecfa7537ed6968886134941bfcc7741ad56ba8ebb429c021046a968db92b1bba89bf1a1d2bb4a0d1
+DIST thunar-archive-plugin-0.3.1.tar.bz2 329005 BLAKE2B f1cc88acb86565c001734ae2ead50f79cd4e922922292446b3775a7ef5cce250787b202ef6633d453b40bf37f1841d6e1b9ee34350e784587612ea0d4030e6d4 SHA512 51157c2680b3fcc6b541d35fc2943a350a0354d7d5bbb5fbe8a9dcbbeaf4bf4f5fe62521b8e9a73254f70bbefc440357deade8181313da96270c280eb0464e68
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r3.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r3.ebuild
new file mode 100644
index 000000000000..b8388f2596f6
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/thunar-1.2:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/0.3.1-add-engrampa-support.patch
+ "${FILESDIR}"/0.3.1-fix-kde-ark.patch
+ "${FILESDIR}"/0.3.1-add-support-symlinks.patch
+ )
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}