summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-mailwatch-plugin')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/metadata.xml8
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild41
3 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/Manifest b/xfce-extra/xfce4-mailwatch-plugin/Manifest
new file mode 100644
index 000000000000..1e2c51fbc81a
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/Manifest
@@ -0,0 +1 @@
+DIST xfce4-mailwatch-plugin-1.2.0.tar.bz2 509649 SHA256 624acc8229a8593c0dfeb28f883f4958119a715cc81cecdbaf29efc8ab1edcad SHA512 6f5128b2341ab275427e02b1ef063cb2fdcf4027f5c47cfc0ed26086462eb0e9f7353441ea1b9380b91a892414934203b781445f604d67200786e3dd85183a83 WHIRLPOOL 187d636667480db2050c5f75c74f57af7a2ce1476c55d0317cca0d2a54b1d27b2c41ae0af5a2c015f92066859d186d71f53ce88ef9f5038e1befcf89614780cd
diff --git a/xfce-extra/xfce4-mailwatch-plugin/metadata.xml b/xfce-extra/xfce4-mailwatch-plugin/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild
new file mode 100644
index 000000000000..9014ad2c3b21
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="http://spuriousinterrupt.org/projects/xfce4-mailwatch-plugin/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=dev-libs/glib-2
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ >=xfce-base/exo-0.7.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ ssl? (
+ dev-libs/libgcrypt:0
+ >=net-libs/gnutls-2
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable ssl)
+ $(use_enable ipv6)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}