summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-mixer')
-rw-r--r--xfce-extra/xfce4-mixer/Manifest2
-rw-r--r--xfce-extra/xfce4-mixer/metadata.xml11
-rw-r--r--xfce-extra/xfce4-mixer/xfce4-mixer-4.10.0.ebuild40
-rw-r--r--xfce-extra/xfce4-mixer/xfce4-mixer-4.11.0.ebuild41
4 files changed, 94 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mixer/Manifest b/xfce-extra/xfce4-mixer/Manifest
new file mode 100644
index 000000000000..34e9c154e12b
--- /dev/null
+++ b/xfce-extra/xfce4-mixer/Manifest
@@ -0,0 +1,2 @@
+DIST xfce4-mixer-4.10.0.tar.bz2 461526 SHA256 a8c589001b438171ea5a6b46ce9895c3ffbc5081ab67805ab9870e540068dade SHA512 83c12101c034a71039f3a481c1026430cd9b23c3a3d1c6e57697eb4484700a2403143d94dfdd2bb28552e38b4637afb6370a6400571ec6cdb55cc59f5f7a67ae WHIRLPOOL 59959b48e7281a082784930d1bc5d6ae4b3732f1248847b188fd6116b3cf1ce764bfe5d4fc800589adad13cf168d7f6d167e29865196a5db385f6ca094815980
+DIST xfce4-mixer-4.11.0.tar.bz2 472235 SHA256 fb0c1df201ed1130f54f15b914cbe5a59286e994a137acda5609570c57112de2 SHA512 0ef27ece0d5f46bd83db86d8e607d2dc34f4b0221679dbdeae4e4eb9993b30398a2e882b3a870af9928906330898935f2fe29e83442ba6f01b9e19d02ea6f66f WHIRLPOOL 58ebbe509e89d7bf3dded809a9466094287e53d7c0ed905c6c5e3bf70ac8810d9ad174a1dc082940c77b55117e6931d067f24dd46b8c09ce1fd1f6c39fa96492
diff --git a/xfce-extra/xfce4-mixer/metadata.xml b/xfce-extra/xfce4-mixer/metadata.xml
new file mode 100644
index 000000000000..ec535fcae23a
--- /dev/null
+++ b/xfce-extra/xfce4-mixer/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <use>
+ <flag name='keybinder'>Enable shortcut support using <pkg>dev-libs/keybinder</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-mixer/xfce4-mixer-4.10.0.ebuild b/xfce-extra/xfce4-mixer/xfce4-mixer-4.10.0.ebuild
new file mode 100644
index 000000000000..79eadfc04250
--- /dev/null
+++ b/xfce-extra/xfce4-mixer/xfce4-mixer-4.10.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A volume control application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-mixer/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~hppa ~mips ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="alsa debug oss"
+
+COMMON_DEPEND=">=dev-libs/glib-2.24
+ dev-libs/libunique:1
+ dev-libs/keybinder:0
+ media-libs/gst-plugins-base:0.10
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10"
+RDEPEND="${COMMON_DEPEND}
+ alsa? ( media-plugins/gst-plugins-alsa:0.10 )
+ oss? ( media-plugins/gst-plugins-oss:0.10 )
+ !alsa? ( !oss? ( media-plugins/gst-plugins-meta:0.10 ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
diff --git a/xfce-extra/xfce4-mixer/xfce4-mixer-4.11.0.ebuild b/xfce-extra/xfce4-mixer/xfce4-mixer-4.11.0.ebuild
new file mode 100644
index 000000000000..956dba945c01
--- /dev/null
+++ b/xfce-extra/xfce4-mixer/xfce4-mixer-4.11.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A volume control application (and panel plug-in) for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-mixer/"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~hppa ~mips ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
+IUSE="alsa debug +keybinder oss"
+
+COMMON_DEPEND=">=dev-libs/glib-2.24
+ dev-libs/libunique:1
+ media-libs/gst-plugins-base:0.10
+ >=x11-libs/gtk+-2.20:2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10
+ keybinder? ( dev-libs/keybinder:0 )"
+RDEPEND="${COMMON_DEPEND}
+ alsa? ( media-plugins/gst-plugins-alsa:0.10 )
+ oss? ( media-plugins/gst-plugins-oss:0.10 )
+ !alsa? ( !oss? ( media-plugins/gst-plugins-meta:0.10 ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable keybinder)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}