summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-radio-plugin')
-rw-r--r--xfce-extra/xfce4-radio-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-radio-plugin/metadata.xml8
-rw-r--r--xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild33
-rw-r--r--xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1.ebuild30
4 files changed, 72 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-radio-plugin/Manifest b/xfce-extra/xfce4-radio-plugin/Manifest
new file mode 100644
index 000000000000..be7222f878ab
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/Manifest
@@ -0,0 +1 @@
+DIST xfce4-radio-plugin-0.5.1.tar.bz2 137447 SHA256 82921775cd8b1633cfc15581b35d7dabafbe6e1431d385919369dfb1591e13cb SHA512 54cc25c965dd6d220019382d0cc0970bffc3b9eaf315f2b055ee2ed56f818066e1fa51d2613c04b74562ec4f4786e9b87197a791c3e7867038b9b2737c540e09 WHIRLPOOL 0597a23fe2f51505786b8d9fe7cddc91764a8d95ecc39a015d2b6e70d32c4b763246e13dc677032e15e4dbb7c5c8c902e8662fef6b8424ad71fc0b21c87f88e9
diff --git a/xfce-extra/xfce4-radio-plugin/metadata.xml b/xfce-extra/xfce4-radio-plugin/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..1d664dbcf35e
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic multilib xfconf
+
+DESCRIPTION="V4L radio device control plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-radio-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfcegui4-4.8:=
+ >=xfce-base/xfce4-panel-4.8:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS NEWS README )
+
+ # fix underlinking, bug #555056
+ append-libs -lm
+}
diff --git a/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1.ebuild b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1.ebuild
new file mode 100644
index 000000000000..8260574650fc
--- /dev/null
+++ b/xfce-extra/xfce4-radio-plugin/xfce4-radio-plugin-0.5.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="V4L radio device control plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-radio-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS NEWS README )
+}