summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-soundmenu-plugin')
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/metadata.xml16
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild40
-rw-r--r--xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild42
4 files changed, 100 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-soundmenu-plugin/Manifest b/xfce-extra/xfce4-soundmenu-plugin/Manifest
new file mode 100644
index 000000000000..c387a5bc7b7a
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/Manifest
@@ -0,0 +1,2 @@
+DIST xfce4-soundmenu-plugin-0.6.0.tar.bz2 325349 SHA256 ff37c687ef29fd27ad14c06da447d44da4143760644b030451ca6067c111dfcd SHA512 665f1efffc9b8b194f8b285f23c284ac1f6dac0a2c63ba9380017d9045f76e8952295028f6bc4756e2805ad6d4d9d7b069ca44e89c645d00e78ed5a21827919e WHIRLPOOL bef97a66775740cf2bee74e0123ecb3176ef5613dd133ecbe677cffe061caee0bda0c2f16706979301fdf80def0eede760e9eb4d2de525b46eea9288eac5cc61
+DIST xfce4-soundmenu-plugin-0.7.0.tar.bz2 386162 SHA256 d8a8d86ffc09363984e4014ae188c1c01c51df665666a081188483c36ed871ff SHA512 d0f5815f70a64d8b68b7257d90697dddb465e77b0acfa4d0b75c4dd23864e4b3d2e58526932d9a5a9fdabbbdf2e8e3b24f8e5f26ad93e864dfe614139f7d3748 WHIRLPOOL 782752b2d69ab4301712025d5dace1fcebe4a41d594e24e3ec2bb15ca9a8de65213c82ece2cb208bbd638c0ba8cbe73064342d970d166c6336d6ca882ac9863a
diff --git a/xfce-extra/xfce4-soundmenu-plugin/metadata.xml b/xfce-extra/xfce4-soundmenu-plugin/metadata.xml
new file mode 100644
index 000000000000..c24e733f76ef
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <use>
+ <flag name="glyr">Enable music metadata searchengine support using <pkg>media-libs/glyr</pkg></flag>
+ <flag name="lastfm">Enable last.fm support using <pkg>media-libs/libclastfm</pkg></flag>
+ <flag name="keybinder">Enable shortcut support using <pkg>dev-libs/keybinder</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">matiasdelellis/xfce4-soundmenu-plugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
new file mode 100644
index 000000000000..0f15d09c0d14
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to control MPRIS2 compatible players like Pragha (from the same authors)"
+HOMEPAGE="https://github.com/matiasdelellis/xfce4-soundmenu-plugin"
+SRC_URI="http://dissonance.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +glyr lastfm +keybinder"
+
+RDEPEND=">=dev-libs/glib-2.28
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ glyr? ( >=media-libs/glyr-1.0.0 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )
+ keybinder? ( >=dev-libs/keybinder-0.2.2:0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable keybinder)
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}
diff --git a/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild
new file mode 100644
index 000000000000..db7ac3f50ba2
--- /dev/null
+++ b/xfce-extra/xfce4-soundmenu-plugin/xfce4-soundmenu-plugin-0.7.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plug-in to control MPRIS2 compatible players like Pragha (from the same authors)"
+HOMEPAGE="http://github.com/matiasdelellis/xfce4-soundmenu-plugin"
+SRC_URI="http://github.com/matiasdelellis/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug +glyr lastfm +keybinder"
+
+RDEPEND=">=dev-libs/glib-2.28
+ >=media-libs/libmpris2client-0.1
+ >=media-sound/pulseaudio-2[glib]
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ glyr? ( >=media-libs/glyr-1.0.0 )
+ lastfm? ( >=media-libs/libclastfm-0.5 )
+ keybinder? ( >=dev-libs/keybinder-0.2.2:0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable keybinder)
+ $(use_enable lastfm libclastfm)
+ $(use_enable glyr libglyr)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}