summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-qt/qtdeclarative: use QT6_RESTRICT_TESTSIonen Wolkens3 days3-12/+15
| | | | | | | | | | | | Seemingly started to failing building entirely with USE="test", and there is likely more problems haven't been handling given been RESTRICT'ing for a while. So let's not leave a broken flag. May revisit eventually if test suite is improved upstream, attempting to make this one work was a headache I'd rather not revisit yet. Closes: https://bugs.gentoo.org/930266 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: drop 6.6.2-r1, 6.6.3Ionen Wolkens4 days3-68/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: add IUSE=qmlls for same-named user-facing toolIonen Wolkens7 days4-3/+10
| | | | | | | | | | | | Masked in stable for now, will stabilize qtlanguageserver-6.7.0 in a few days to match the rest. Was automagic before but don't really need to revbump given the required package wasn't in the tree and fairly harmless even if someone had it from elsewhere. Closes: https://bugs.gentoo.org/930106 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 6.7.0 amd64, #929242Arthur Zamarin10 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 6.7.0 arm64, #929242Arthur Zamarin10 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: drop 5.15.12Andreas Sturmlechner2024-04-052-69/+0
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.13 arm64, #927748Arthur Zamarin2024-04-041-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.13 x86, #927748Arthur Zamarin2024-04-031-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.13 amd64, #927748Arthur Zamarin2024-04-031-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.13 ppc64, #927748Arthur Zamarin2024-04-031-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.13 ppc, #927748Arthur Zamarin2024-04-031-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.13 arm, #927748Arthur Zamarin2024-04-031-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: add 6.7.0Ionen Wolkens2024-04-022-0/+44
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: drop 6.7.0_rc2Ionen Wolkens2024-04-022-40/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 6.6.3 arm64, #928382Arthur Zamarin2024-04-021-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 6.6.3 amd64, #928382Arthur Zamarin2024-04-011-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: fix qtsvg automagic in 6.7+Ionen Wolkens2024-03-292-4/+12
| | | | | | | | | | | | | | | Qt6Svg been checked by the build system for a long time but was only used for unused examples and (manual) tests and so was ignored. ...but 6.7 adds a svgtoqml tool which actually links with it and is otherwise skipped without qtsvg. Doesn't seem very interesting, so left off-by-default for now. Could change if something needs it, albeit USE=svg is default on desktop profiles either way. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: drop 6.6.9999Ionen Wolkens2024-03-291-33/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: add 6.6.3Ionen Wolkens2024-03-262-0/+34
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: drop 6.7.0_rc-r1Ionen Wolkens2024-03-242-40/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: 5.15.13 version bumpAndreas Sturmlechner2024-03-232-0/+69
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtdeclarative: add 6.7.0_rc2Ionen Wolkens2024-03-222-0/+40
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 6.6.2-r1 arm64, #927197Arthur Zamarin2024-03-221-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: do qtbase:6[accessibility=] matching nowIonen Wolkens2024-03-142-4/+4
| | | | | | | | | | | | | Backported from live ebuilds, albeit still skipping it for qtwebengine given few users should be affected and there should be the 6.6.3 release in bit over a week (not worth a rebuild now). Mostly a side effect of kwin-6 (formerly) requiring it so users enabled it only for it and then disable after it no longer is. Typical accessibility users likely leave it enabled globally. Closes: https://bugs.gentoo.org/926992 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: match accessibility IUSE with qtbase:6Ionen Wolkens2024-03-123-6/+6
| | | | | | | | | | | | | | | Makes use of QT_CONFIG(accessibility) which can result in undefined symbols if was enabled on qtbase then flipped off. Like opengl/vulkan, this flag is typically enabled either globally or not at all and should hopefully not cause conflicts for most users. Technically needed in non-live but given the low impact will wait rather than let this trigger rebuilds (esp. given one of the similarly affected package is qtwebengine). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: add 6.7.0_rcIonen Wolkens2024-03-122-0/+40
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: drop 6.6.1Ionen Wolkens2024-02-222-34/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 6.6.2 amd64, #924651Arthur Zamarin2024-02-201-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: add missing qtbase[gui] dependency (qt6)Ionen Wolkens2024-02-154-4/+4
| | | | | | | | | | | Exists in qt5's ebuild but seem to have went missing/overlooked here, and noticed that this skips Quick entirely if gui is missing. Albeit not really worth a revbump (slow rebuild), and disabling gui is very unusual (the default IUSE=+widgets would also request gui to be set on qtbase). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: add 6.6.2Ionen Wolkens2024-02-142-0/+34
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: drop 5.15.11-r2Andreas Sturmlechner2024-02-022-69/+0
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.12 arm, #921565Matoro Mahri2024-01-311-1/+1
| | | | | Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.12 arm64, #921565Matoro Mahri2024-01-311-1/+1
| | | | | Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-qt/*: sync keywords in live (qt6)Ionen Wolkens2024-01-303-6/+6
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.12 ppc, #921565Matoro Mahri2024-01-291-1/+1
| | | | | Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.12 x86, #921565Matoro Mahri2024-01-291-1/+1
| | | | | Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.12 ppc64, #921565Matoro Mahri2024-01-291-1/+1
| | | | | Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.12 amd64, #921565Matoro Mahri2024-01-281-1/+1
| | | | | Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: add 5.15.12Andreas Sturmlechner2024-01-012-0/+69
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtdeclarative: drop 5.15.11-r1Andreas Sturmlechner2023-12-192-68/+0
| | | | Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
* dev-qt/qtdeclarative: drop 6.5.3Ionen Wolkens2023-12-192-36/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.11-r2 x86, #917797Arthur Zamarin2023-12-181-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 6.6.1 amd64, #920154Arthur Zamarin2023-12-171-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-qt/qtdeclarative: Stabilize 5.15.11-r2 ppc64, #917797Sam James2023-12-161-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-qt/qtdeclarative: add 6.7.9999Ionen Wolkens2023-12-121-0/+39
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: update liveIonen Wolkens2023-12-122-4/+11
| | | | | | | Can avoid the more typical = for ssl ([ssl=]) thanks to having no uncontrolled QT_FEATURE_ssl automagic, but there is some for network. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: drop 6.6.0Ionen Wolkens2023-12-122-34/+0
| | | | Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
* dev-qt/qtdeclarative: Keyword 6.6.1 riscv, #914026Jakov Smolić2023-12-011-1/+1
| | | | Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* dev-qt/qtdeclarative: Keyword 6.6.1 ppc64, #914026Sam James2023-12-011-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-qt/qtdeclarative: Keyword 6.6.1 sparc, #914026Sam James2023-12-011-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>