summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-10-03 05:24:41 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-10-03 05:24:41 +0000
commitdbbf4ad1dffc18468027e554fba93fa3f14a238a (patch)
treeebddc72be396a014735612a9b7676f3088e7134b /dev-lang/smlnj
parentAdded a patch to resolve gcc-3.3 and -ansi clfags issues; Closes Bug #30207 (diff)
downloadhistorical-dbbf4ad1dffc18468027e554fba93fa3f14a238a.tar.gz
historical-dbbf4ad1dffc18468027e554fba93fa3f14a238a.tar.bz2
historical-dbbf4ad1dffc18468027e554fba93fa3f14a238a.zip
Added a patch to resolve gcc-3.3 and -ansi clfags issues; Closes Bug #30207
Diffstat (limited to 'dev-lang/smlnj')
-rw-r--r--dev-lang/smlnj/Manifest4
-rw-r--r--dev-lang/smlnj/files/smlnj-110.43-gcc33-quirk-fix.patch17
-rw-r--r--dev-lang/smlnj/smlnj-110.43.ebuild9
3 files changed, 26 insertions, 4 deletions
diff --git a/dev-lang/smlnj/Manifest b/dev-lang/smlnj/Manifest
index 6a966adfd8ae..904ed030171a 100644
--- a/dev-lang/smlnj/Manifest
+++ b/dev-lang/smlnj/Manifest
@@ -1,7 +1,7 @@
-MD5 1818aa84b1516383b4c95129f0a1c7dd ChangeLog 868
+MD5 559a18affabfc7c6cebe0bbee54c1085 ChangeLog 867
MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 52cba1f042316f460c946015695e80d1 smlnj-110.42.ebuild 2285
-MD5 f2451dd930b9a7c6d6caf89b4a6968c6 smlnj-110.43.ebuild 2504
+MD5 8560c2fd152e0e756d6d893422d4b55f smlnj-110.43.ebuild 2503
MD5 50048fd027712df53a1839a96ea71b92 files/digest-smlnj-110.42 501
MD5 50048fd027712df53a1839a96ea71b92 files/digest-smlnj-110.43 501
MD5 b371210cdd42e09c4c6c5d318d08109e files/smlnj-110.43-gcc33-quirk-fix.patch 501
diff --git a/dev-lang/smlnj/files/smlnj-110.43-gcc33-quirk-fix.patch b/dev-lang/smlnj/files/smlnj-110.43-gcc33-quirk-fix.patch
new file mode 100644
index 000000000000..e54077f5f151
--- /dev/null
+++ b/dev-lang/smlnj/files/smlnj-110.43-gcc33-quirk-fix.patch
@@ -0,0 +1,17 @@
+diff -Naurp src.orig/runtime/objs/mk.x86-linux src/runtime/objs/mk.x86-linux
+--- src.orig/runtime/objs/mk.x86-linux 2002-04-12 13:54:31.000000000 -0400
++++ src/runtime/objs/mk.x86-linux 2003-10-02 19:05:56.000000000 -0400
+@@ -4,10 +4,10 @@
+ SHELL = /bin/sh
+
+ MAKE = make
+-CC = gcc -ansi
++CC = gcc
+ CFLAGS = -O2
+ #CPP = gcc -x c -E -P -ansi
+-CPP = gcc -x assembler-with-cpp -E -P -ansi
++CPP = gcc -x assembler-with-cpp -E -P
+ #XOBJS = xmonitor.o
+ #LD_LIBS = -lX11
+ #BASE_DEFS = -DHEAP_MONITOR
+
diff --git a/dev-lang/smlnj/smlnj-110.43.ebuild b/dev-lang/smlnj/smlnj-110.43.ebuild
index dbdd74ebb168..fc5948d07abf 100644
--- a/dev-lang/smlnj/smlnj-110.43.ebuild
+++ b/dev-lang/smlnj/smlnj-110.43.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/smlnj/smlnj-110.43.ebuild,v 1.1 2003/10/01 00:33:48 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/smlnj/smlnj-110.43.ebuild,v 1.2 2003/10/03 05:24:38 kumba Exp $
IUSE=""
@@ -18,7 +18,7 @@ SRC_URI="ftp://ftp.research.bell-labs.com/dist/smlnj/working/${PV}/config.tgz
HOMEPAGE="http://cm.bell-labs.com/cm/cs/what/smlnj/"
LICENSE="BSD"
-KEYWORDS="~x86"
+KEYWORDS="-* ~x86"
SLOT="0"
DEPEND="virtual/glibc"
@@ -43,6 +43,11 @@ src_unpack() {
done
printf ${GEN_POSIX_NAMES_PATCH} | ed -s ${WORKDIR}/src/runtime/config/gen-posix-names.sh
+
+ # This patch removes -ansi flags from the x86-linux Makefiles because they conflict
+ # with both gcc-3.3 and will cause issues is sysmacros.h is included as well.
+ # Closes Bug #30207
+ epatch ${FILESDIR}/${P}-gcc33-quirk-fix.patch
}
src_compile() {