summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-05-31 02:41:01 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-05-31 02:41:01 +0000
commit0188ee5cb75b2db8f24161f89854d51fd1eaf0dc (patch)
tree778f5f687c0d834fde2c19949975b61bbffb1a44 /dev-lisp/sbcl/files
parentStable on amd64. See bug #133593. (diff)
downloadhistorical-0188ee5cb75b2db8f24161f89854d51fd1eaf0dc.tar.gz
historical-0188ee5cb75b2db8f24161f89854d51fd1eaf0dc.tar.bz2
historical-0188ee5cb75b2db8f24161f89854d51fd1eaf0dc.zip
New upstream version; Fix vanilla-module.mk to install Lisp source in addition to FASL (so SLIME find-definition etc. works).
Package-Manager: portage-2.1_rc2-r3
Diffstat (limited to 'dev-lisp/sbcl/files')
-rw-r--r--dev-lisp/sbcl/files/0.9.13/README.Gentoo30
-rw-r--r--dev-lisp/sbcl/files/0.9.13/customize-target-features.lisp-prefix5
-rw-r--r--dev-lisp/sbcl/files/0.9.13/customize-target-features.lisp-suffix2
-rw-r--r--dev-lisp/sbcl/files/0.9.13/disable-tests-gentoo.patch59
-rw-r--r--dev-lisp/sbcl/files/0.9.13/install-clc.lisp37
-rw-r--r--dev-lisp/sbcl/files/0.9.13/sbcl.sh65
-rw-r--r--dev-lisp/sbcl/files/0.9.13/sbclrc16
-rw-r--r--dev-lisp/sbcl/files/0.9.13/vanilla-module-install-source-gentoo.patch10
-rw-r--r--dev-lisp/sbcl/files/digest-sbcl-0.9.1321
9 files changed, 245 insertions, 0 deletions
diff --git a/dev-lisp/sbcl/files/0.9.13/README.Gentoo b/dev-lisp/sbcl/files/0.9.13/README.Gentoo
new file mode 100644
index 000000000000..4df910faa4f1
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.13/README.Gentoo
@@ -0,0 +1,30 @@
+$Id: README.Gentoo,v 1.1 2006/05/31 02:41:01 mkennedy Exp $
+
+Gentoo GNU/Linux specific notes for SBCL
+----------------------------------------
+
+This is the README.Gentoo file from /usr/share/doc/@PF@/ directory.
+
+ * The Gentoo port uses patches from the Debian project's SBCL port.
+
+ * An SBCL with support for multi-threading on GNU/Linux for the x86 and amd64
+ platforms is available with 'USE="threads" emerge dev-lisp/sbcl'. Note, an
+ NPTL-enabled GLIBC is a requirement beginning with SBCL 0.9.5.
+
+ * asdf-install is installed as sbcl-asdf-install (the man-page is similarly
+ named).
+
+ * Support for the Common Lisp Controller is available.
+
+ * If "nosource" is in your USE flags, then SBCL's source will not be installed
+ (in /usr/lib/sbcl/src).
+
+ * If "unicode" is in your USE flags, then support for SBCL
+ Unicode will be included.
+
+ * If "ldb" is in your USE flags, then support for the SBCL low-level debugger
+ will be included.
+
+If you encounter any problems or have suggestions, use http://bugs.gentoo.org.
+Please don't bother the upstream authors unless you are absolutely certain it is
+not Gentoo-related.
diff --git a/dev-lisp/sbcl/files/0.9.13/customize-target-features.lisp-prefix b/dev-lisp/sbcl/files/0.9.13/customize-target-features.lisp-prefix
new file mode 100644
index 000000000000..40f9a4fc85fa
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.13/customize-target-features.lisp-prefix
@@ -0,0 +1,5 @@
+(lambda (list)
+(flet ((enable (x)
+(pushnew x list))
+(disable (x)
+(setf list (remove x list))))
diff --git a/dev-lisp/sbcl/files/0.9.13/customize-target-features.lisp-suffix b/dev-lisp/sbcl/files/0.9.13/customize-target-features.lisp-suffix
new file mode 100644
index 000000000000..dbbde7adc44e
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.13/customize-target-features.lisp-suffix
@@ -0,0 +1,2 @@
+)
+list)
diff --git a/dev-lisp/sbcl/files/0.9.13/disable-tests-gentoo.patch b/dev-lisp/sbcl/files/0.9.13/disable-tests-gentoo.patch
new file mode 100644
index 000000000000..31094da3c7c3
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.13/disable-tests-gentoo.patch
@@ -0,0 +1,59 @@
+diff -ur sbcl-0.9.13.orig/contrib/sb-bsd-sockets/sb-bsd-sockets.asd sbcl-0.9.13/contrib/sb-bsd-sockets/sb-bsd-sockets.asd
+--- sbcl-0.9.13.orig/contrib/sb-bsd-sockets/sb-bsd-sockets.asd 2006-04-22 15:07:43.000000000 -0500
++++ sbcl-0.9.13/contrib/sb-bsd-sockets/sb-bsd-sockets.asd 2006-04-27 12:13:47.000000000 -0500
+@@ -36,18 +36,3 @@
+
+ (defmethod perform :after ((o load-op) (c (eql (find-system :sb-bsd-sockets))))
+ (provide 'sb-bsd-sockets))
+-
+-#-win32
+-(defmethod perform ((o test-op) (c (eql (find-system :sb-bsd-sockets))))
+- (operate 'load-op 'sb-bsd-sockets-tests)
+- (operate 'test-op 'sb-bsd-sockets-tests))
+-
+-#-win32
+-(defsystem sb-bsd-sockets-tests
+- :depends-on (sb-rt sb-bsd-sockets #-win32 sb-posix)
+- :components ((:file "tests")))
+-
+-#-win32
+-(defmethod perform ((o test-op) (c (eql (find-system :sb-bsd-sockets-tests))))
+- (or (funcall (intern "DO-TESTS" (find-package "SB-RT")))
+- (error "test-op failed")))
+diff -ur sbcl-0.9.13.orig/contrib/sb-posix/sb-posix.asd sbcl-0.9.13/contrib/sb-posix/sb-posix.asd
+--- sbcl-0.9.13.orig/contrib/sb-posix/sb-posix.asd 2006-03-20 10:37:51.000000000 -0600
++++ sbcl-0.9.13/contrib/sb-posix/sb-posix.asd 2006-04-27 12:13:12.000000000 -0500
+@@ -16,33 +16,5 @@
+ :package :sb-posix :depends-on ("defpackage"))
+ (:file "interface" :depends-on ("constants" "macros" "designator"))))
+
+-(defsystem sb-posix-tests
+- :depends-on (sb-rt)
+- :components ((:file "posix-tests")))
+-
+ (defmethod perform :after ((o load-op) (c (eql (find-system :sb-posix))))
+ (provide 'sb-posix))
+-
+-(defmethod perform ((o test-op) (c (eql (find-system :sb-posix))))
+- (operate 'load-op 'sb-posix-tests)
+- (operate 'test-op 'sb-posix-tests))
+-
+-(defmethod perform ((o test-op) (c (eql (find-system :sb-posix-tests))))
+- (funcall (intern "DO-TESTS" (find-package "SB-RT")))
+- (let ((failures (funcall (intern "PENDING-TESTS" "SB-RT")))
+- (ignored-failures (loop for sym being the symbols of :sb-posix-tests
+- if (search ".ERROR" (symbol-name sym))
+- collect sym)))
+- (cond
+- ((null failures)
+- t)
+- ((null (set-difference failures ignored-failures))
+- (warn "~@<some POSIX implementations return incorrect error values for ~
+- failing calls, but there is legitimate variation between ~
+- implementations too. If you think the errno ~
+- from your platform is valid, please contact the sbcl ~
+- developers; otherwise, please submit a bug report to your ~
+- kernel distributor~@:>")
+- t)
+- (t
+- (error "non-errno tests failed!")))))
diff --git a/dev-lisp/sbcl/files/0.9.13/install-clc.lisp b/dev-lisp/sbcl/files/0.9.13/install-clc.lisp
new file mode 100644
index 000000000000..8ae9a3828dff
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.13/install-clc.lisp
@@ -0,0 +1,37 @@
+;;; -*- Mode: LISP; Package: CL-USER -*-
+;;;
+;;; Copyright (C) Peter Van Eynde 2001 and Kevin Rosenberg 2002-2003
+;;;
+;;; License: LGPL v2
+;;;
+
+;; This file is originally from the Debian project patch to SBCL
+;; upstream.
+
+(in-package "COMMON-LISP-USER")
+
+(handler-case
+ (load "/usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp")
+ (error (e)
+ (format t "~%Error during load of common-lisp-controller.lisp: ~A~%" e)
+ (sb-unix:unix-exit 1)))
+
+(handler-case
+ (common-lisp-controller:init-common-lisp-controller-v4 "sbcl")
+ (error (e)
+ (format t "~%Error running init-common-lisp-controller-v4: ~A~%" e)
+ (sb-unix:unix-exit 1)))
+
+(when (probe-file #p"/etc/lisp.config")
+ (load #p"/etc/lisp.config"))
+
+(setf (logical-pathname-translations "SYS")
+ '(("SYS:SRC;**;*.*.*"
+ #P"/usr/share/sbcl/src/**/*.*")
+ ("SYS:CONTRIB;**;*.*.*"
+ #P"/usr/share/sbcl/**/*.*")))
+
+(ignore-errors
+ (format t "~%Saving to sbcl-new.core...")
+ (sb-ext:gc :full t)
+ (sb-ext:save-lisp-and-die "sbcl-new.core"))
diff --git a/dev-lisp/sbcl/files/0.9.13/sbcl.sh b/dev-lisp/sbcl/files/0.9.13/sbcl.sh
new file mode 100644
index 000000000000..6693bd9b4e8b
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.13/sbcl.sh
@@ -0,0 +1,65 @@
+#!/bin/sh
+
+# This file is originally from the Debian project patch to SBCL
+# upstream. It has been modified by the Gentoo project to NOT use
+# /etc/sbcl.rc which has been confusing because SBCL docs refer
+# /etc/sbclrc.
+
+if [ ! -f /usr/share/common-lisp/source/common-lisp-controller/common-lisp-controller.lisp ] ; then
+ cat <<EOF
+$0: cannot find the common-lisp-controller source.
+EOF
+ exit 0
+fi
+
+build_error()
+{
+ echo "Build failure $1"
+ exit 1
+}
+
+case $1 in
+ install-clc)
+ echo $0 loading and dumping clc.
+ ( cd /usr/lib/sbcl
+ /usr/bin/sbcl --core /usr/lib/sbcl/sbcl-dist.core \
+ --noinform --sysinit /etc/sbclrc --userinit /dev/null \
+ --load "/usr/lib/sbcl/install-clc.lisp" # 2> /dev/null
+ mv sbcl-new.core sbcl.core || (echo FAILED ; cp sbcl-dist.core sbcl.core ) )
+ ;;
+ remove-clc)
+ echo $0 removing clc-enabled image
+ cp /usr/lib/sbcl/sbcl-dist.core /usr/lib/sbcl/sbcl.core
+ ;;
+ rebuild)
+ echo $0 rebuilding...
+ shift
+ echo rebuilding $1
+ /usr/bin/sbcl --noinform --sysinit /etc/sbclrc --userinit /dev/null \
+ --disable-debugger \
+ --eval \
+"(handler-case
+ (progn
+ (asdf:operate 'asdf:compile-op (quote $1))
+ (sb-unix:unix-exit 0))
+ (error (e)
+ (ignore-errors (format t \"~&Build error: ~A~%\" e))
+ (finish-output)
+ (sb-unix:unix-exit 1)))" || build_error
+ ;;
+ remove)
+ echo $0 removing packages...
+ shift
+ while [ ! -z "$1" ] ; do
+ rm -rf "/var/cache/common-lisp-controller/*/sbcl/${1}"
+ shift
+ done
+ ;;
+ *)
+ echo $0 unkown command $1
+ echo known commands: rebuild, remove, install-clc, and remove-clc
+ exit 1
+ ;;
+esac
+
+exit 0 \ No newline at end of file
diff --git a/dev-lisp/sbcl/files/0.9.13/sbclrc b/dev-lisp/sbcl/files/0.9.13/sbclrc
new file mode 100644
index 000000000000..bd0ab76b6adf
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.13/sbclrc
@@ -0,0 +1,16 @@
+;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Package: CL-USER -*-
+
+;;; This file is installed as /etc/sbclrc and run on every invocation
+;;; of SBCL
+
+(if (probe-file "/etc/lisp-config.lisp")
+ (load "/etc/lisp-config.lisp")
+ (format t "~%;;; Warning: there is no /etc/lisp-config.lisp file"))
+
+;;; The following is required if you want source location functions to
+;;; work (such as those called when you use M-. (edit definition) in
+;;; ILISP or SLIME)
+
+(setf (logical-pathname-translations "SYS")
+ '(("SYS:SRC;**;*.*.*" #p"/usr/lib/sbcl/src/**/*.*")
+ ("SYS:CONTRIB;**;*.*.*" #p"/usr/lib/sbcl/**/*.*")))
diff --git a/dev-lisp/sbcl/files/0.9.13/vanilla-module-install-source-gentoo.patch b/dev-lisp/sbcl/files/0.9.13/vanilla-module-install-source-gentoo.patch
new file mode 100644
index 000000000000..6a4a0d2c20b5
--- /dev/null
+++ b/dev-lisp/sbcl/files/0.9.13/vanilla-module-install-source-gentoo.patch
@@ -0,0 +1,10 @@
+diff -ur sbcl-0.9.13.orig/contrib/vanilla-module.mk sbcl-0.9.13/contrib/vanilla-module.mk
+--- sbcl-0.9.13.orig/contrib/vanilla-module.mk 2003-11-08 09:04:47.000000000 -0600
++++ sbcl-0.9.13/contrib/vanilla-module.mk 2006-05-29 22:49:12.000000000 -0500
+@@ -5,4 +5,4 @@
+ test:: $(MODULE).fasl
+
+ install:
+- cp $(MODULE).fasl $(BUILD_ROOT)$(INSTALL_DIR)
++ cp $(MODULE).fasl $(MODULE).lisp $(BUILD_ROOT)$(INSTALL_DIR)
+Only in sbcl-0.9.13/contrib: vanilla-module.mk.~1.5.~
diff --git a/dev-lisp/sbcl/files/digest-sbcl-0.9.13 b/dev-lisp/sbcl/files/digest-sbcl-0.9.13
new file mode 100644
index 000000000000..5f9e1afc50cd
--- /dev/null
+++ b/dev-lisp/sbcl/files/digest-sbcl-0.9.13
@@ -0,0 +1,21 @@
+MD5 29ad145f1fc45c65b8d65b39013bc43f sbcl-0.7.10-mips-linux-binary.tar.gz 7473873
+RMD160 d9c34e109dd307bfe652ef57d5837c83cbc60055 sbcl-0.7.10-mips-linux-binary.tar.gz 7473873
+SHA256 90bff80973c3e295b5ecdd0b59525583ae04cb2d5967378af65e04ac77fad660 sbcl-0.7.10-mips-linux-binary.tar.gz 7473873
+MD5 3a72d0785ce0a8e02f9af632c2a4f217 sbcl-0.8.15-powerpc-linux-binary.tar.bz2 6656148
+RMD160 0e73b6e96f0170d44be60dfde8bf580596d3a6ee sbcl-0.8.15-powerpc-linux-binary.tar.bz2 6656148
+SHA256 fef30a771530096c4f190c60d9d7c396844fc67a3ec2bbaae9b0ff497f925129 sbcl-0.8.15-powerpc-linux-binary.tar.bz2 6656148
+MD5 029b85186984d0bfc8b49c4de1e8e45e sbcl-0.8.15-sparc-linux-binary.tar.bz2 6903090
+RMD160 41015dcfb41caf93b54a02a0f55eec994309accf sbcl-0.8.15-sparc-linux-binary.tar.bz2 6903090
+SHA256 f0bc5fc11e9c0f1651ebe773b5c7e972da589cc4af2811d25438a099f490cc7d sbcl-0.8.15-sparc-linux-binary.tar.bz2 6903090
+MD5 46d67859cac0d3b748310a93311b308a sbcl-0.9.11a-powerpc-darwin-binary.tar.bz2 6766401
+RMD160 c60dba2a0278acf787d53a93ebac4de03c1d5ed8 sbcl-0.9.11a-powerpc-darwin-binary.tar.bz2 6766401
+SHA256 5cb563b19d1dd828e55bde9763404f5b908c9f5a043ba8c443415291b969b3d9 sbcl-0.9.11a-powerpc-darwin-binary.tar.bz2 6766401
+MD5 1423210cc88b6c373f1db3dccc76acf6 sbcl-0.9.13-source.tar.bz2 2743731
+RMD160 7645085808ed3f97d859d686f53a3b2397825b79 sbcl-0.9.13-source.tar.bz2 2743731
+SHA256 624dd895fabf8e34bd2418293bc43bab85688e93433ceb60f91d86123b2ef6e9 sbcl-0.9.13-source.tar.bz2 2743731
+MD5 900ae4d2353fd9371d6ebaef40180038 sbcl-0.9.8-x86-linux-binary.tar.bz2 7325645
+RMD160 1e0c1b6cdbe7dc51200e63bc4b5641c27270e9ff sbcl-0.9.8-x86-linux-binary.tar.bz2 7325645
+SHA256 85b7861a203747a7584107eedcbfc44c33dfe8b9ff528095398d5ed91e35cb2b sbcl-0.9.8-x86-linux-binary.tar.bz2 7325645
+MD5 d9e4a6d95e255b3a24431f336fae236d sbcl-0.9.9-x86-64-linux-binary.tar.bz2 7102295
+RMD160 6899b82bda2af193783817a0f2ec054e76b08eeb sbcl-0.9.9-x86-64-linux-binary.tar.bz2 7102295
+SHA256 a2d7de87fbfcd7b19acd577ddefdf60adc69f80a15a0593a1e24aeee59aa048e sbcl-0.9.9-x86-64-linux-binary.tar.bz2 7102295