summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2012-04-07 10:58:44 +0000
committerJesus Rivero <neurogeek@gentoo.org>2012-04-07 10:58:44 +0000
commit6d9a386358bb824e51ae526e5337335dd028c4fe (patch)
treeabceebd4e0cba3560ac282ede1564a1838648900 /dev-lisp/sbcl/files
parentChanged DEPEND to depend on dev-lisp/asdf instead of dev-lisp/cl-asdf (diff)
downloadhistorical-6d9a386358bb824e51ae526e5337335dd028c4fe.tar.gz
historical-6d9a386358bb824e51ae526e5337335dd028c4fe.tar.bz2
historical-6d9a386358bb824e51ae526e5337335dd028c4fe.zip
Removed older versions
Package-Manager: portage-2.2.0_alpha95/cvs/Linux i686
Diffstat (limited to 'dev-lisp/sbcl/files')
-rw-r--r--dev-lisp/sbcl/files/disable-tests-gentoo.patch54
-rw-r--r--dev-lisp/sbcl/files/gentoo-fix_install_man.patch12
-rw-r--r--dev-lisp/sbcl/files/gentoo-fix_linux-os-c.patch (renamed from dev-lisp/sbcl/files/sbcl-1.0.36-fix_linux-os-c.patch)1
-rw-r--r--dev-lisp/sbcl/files/gentoo-fix_nopie_for_hardened_toolchain.patch24
-rw-r--r--dev-lisp/sbcl/files/gentoo_fix_waitpid_c.patch11
-rw-r--r--dev-lisp/sbcl/files/sbcl-1.0.55_no_doc_install.patch61
-rw-r--r--dev-lisp/sbcl/files/vanilla-module-install-source-gentoo.patch10
7 files changed, 108 insertions, 65 deletions
diff --git a/dev-lisp/sbcl/files/disable-tests-gentoo.patch b/dev-lisp/sbcl/files/disable-tests-gentoo.patch
deleted file mode 100644
index d68ee4250ba6..000000000000
--- a/dev-lisp/sbcl/files/disable-tests-gentoo.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-diff -ur sbcl-0.9.14.orig/contrib/sb-bsd-sockets/sb-bsd-sockets.asd sbcl-0.9.17/contrib/sb-bsd-sockets/sb-bsd-sockets.asd
---- sbcl-0.9.17.orig/contrib/sb-bsd-sockets/sb-bsd-sockets.asd 2006-06-09 09:11:29.000000000 -0500
-+++ sbcl-0.9.17/contrib/sb-bsd-sockets/sb-bsd-sockets.asd 2006-07-09 11:42:19.000000000 -0500
-@@ -42,19 +42,3 @@
-
- (defmethod perform :after ((o load-op) (c (eql (find-system :sb-bsd-sockets))))
- (provide 'sb-bsd-sockets))
--
--#-win32
--(defmethod perform ((o test-op) (c (eql (find-system :sb-bsd-sockets))))
-- (operate 'load-op 'sb-bsd-sockets-tests)
-- (operate 'test-op 'sb-bsd-sockets-tests))
--
--#-win32
--(defsystem sb-bsd-sockets-tests
-- :depends-on (sb-rt sb-bsd-sockets #-win32 sb-posix)
-- :components ((:file "tests")))
--
--#-win32
--(defmethod perform ((o test-op) (c (eql (find-system :sb-bsd-sockets-tests))))
-- (or (funcall (intern "DO-TESTS" (find-package "SB-RT")))
-- (error "test-op failed")))
--
-diff -ur sbcl-0.9.17.orig/contrib/sb-posix/sb-posix.asd sbcl-0.9.17/contrib/sb-posix/sb-posix.asd
---- sbcl-0.9.17.orig/contrib/sb-posix/sb-posix.asd 2006-03-07 06:04:27.000000000 -0600
-+++ sbcl-0.9.17/contrib/sb-posix/sb-posix.asd 2006-07-09 11:43:16.000000000 -0500
-@@ -22,27 +22,3 @@
-
- (defmethod perform :after ((o load-op) (c (eql (find-system :sb-posix))))
- (provide 'sb-posix))
--
--(defmethod perform ((o test-op) (c (eql (find-system :sb-posix))))
-- (operate 'load-op 'sb-posix-tests)
-- (operate 'test-op 'sb-posix-tests))
--
--(defmethod perform ((o test-op) (c (eql (find-system :sb-posix-tests))))
-- (funcall (intern "DO-TESTS" (find-package "SB-RT")))
-- (let ((failures (funcall (intern "PENDING-TESTS" "SB-RT")))
-- (ignored-failures (loop for sym being the symbols of :sb-posix-tests
-- if (search ".ERROR" (symbol-name sym))
-- collect sym)))
-- (cond
-- ((null failures)
-- t)
-- ((null (set-difference failures ignored-failures))
-- (warn "~@<some POSIX implementations return incorrect error values for ~
-- failing calls, but there is legitimate variation between ~
-- implementations too. If you think the errno ~
-- from your platform is valid, please contact the sbcl ~
-- developers; otherwise, please submit a bug report to your ~
-- kernel distributor~@:>")
-- t)
-- (t
-- (error "non-errno tests failed!")))))
diff --git a/dev-lisp/sbcl/files/gentoo-fix_install_man.patch b/dev-lisp/sbcl/files/gentoo-fix_install_man.patch
new file mode 100644
index 000000000000..87a5f43c0c13
--- /dev/null
+++ b/dev-lisp/sbcl/files/gentoo-fix_install_man.patch
@@ -0,0 +1,12 @@
+diff --git a/install.sh b/install.sh
+index 1400791..ac149c1 100644
+--- a/install.sh
++++ b/install.sh
+@@ -106,6 +106,7 @@ echo "Documentation:"
+
+ # man
+ cp doc/sbcl.1 "$BUILD_ROOT$MAN_DIR"/man1/ && echo " man $BUILD_ROOT$MAN_DIR/man1/sbcl.1"
++cp doc/sbcl-asdf-install.1 "$BUILD_ROOT$MAN_DIR"/man1/ && echo " man $BUILD_ROOT$MAN_DIR/man1/sbcl-asdf-install.1"
+
+ # info
+ for info in doc/manual/*.info
diff --git a/dev-lisp/sbcl/files/sbcl-1.0.36-fix_linux-os-c.patch b/dev-lisp/sbcl/files/gentoo-fix_linux-os-c.patch
index b5c593051186..cabfafe6e45e 100644
--- a/dev-lisp/sbcl/files/sbcl-1.0.36-fix_linux-os-c.patch
+++ b/dev-lisp/sbcl/files/gentoo-fix_linux-os-c.patch
@@ -11,4 +11,3 @@
-#endif
size_t os_vm_page_size;
-
diff --git a/dev-lisp/sbcl/files/gentoo-fix_nopie_for_hardened_toolchain.patch b/dev-lisp/sbcl/files/gentoo-fix_nopie_for_hardened_toolchain.patch
new file mode 100644
index 000000000000..d4f94ca2382f
--- /dev/null
+++ b/dev-lisp/sbcl/files/gentoo-fix_nopie_for_hardened_toolchain.patch
@@ -0,0 +1,24 @@
+diff -ur b/src/runtime/Config.x86-linux a/src/runtime/Config.x86-linux
+--- b/src/runtime/Config.x86-linux 2012-01-09 02:08:10.000000000 +0000
++++ a/src/runtime/Config.x86-linux 2012-02-02 14:32:56.000000000 +0000
+@@ -27,7 +27,7 @@
+ # (You *are* encouraged to design and implement a coherent stable
+ # interface, though.:-| As far as I (WHN 2002-05-19) know, no one is
+ # working on one and it would be a nice thing to have.)
+-LINKFLAGS += -Wl,--export-dynamic -m32
++LINKFLAGS += -Wl,--export-dynamic -m32 -nopie
+ OS_LIBS = -ldl
+
+ ifdef LISP_FEATURE_LARGEFILE
+diff -ur b/src/runtime/Config.x86_64-linux a/src/runtime/Config.x86_64-linux
+--- b/src/runtime/Config.x86_64-linux 2012-01-09 02:08:10.000000000 +0000
++++ a/src/runtime/Config.x86_64-linux 2012-02-02 14:32:44.000000000 +0000
+@@ -27,7 +27,7 @@
+ # (You *are* encouraged to design and implement a coherent stable
+ # interface, though.:-| As far as I (WHN 2002-05-19) know, no one is
+ # working on one and it would be a nice thing to have.)
+-LINKFLAGS += -Wl,--export-dynamic
++LINKFLAGS += -Wl,--export-dynamic -nopie
+ OS_LIBS = -ldl
+
+ ifdef LISP_FEATURE_LARGEFILE
diff --git a/dev-lisp/sbcl/files/gentoo_fix_waitpid_c.patch b/dev-lisp/sbcl/files/gentoo_fix_waitpid_c.patch
new file mode 100644
index 000000000000..33b89b224f29
--- /dev/null
+++ b/dev-lisp/sbcl/files/gentoo_fix_waitpid_c.patch
@@ -0,0 +1,11 @@
+diff -uNr sbcl-1.0.55.orig/src/runtime/run-program.c sbcl-1.0.55/src/runtime/run-program.c
+--- a/src/runtime/run-program.c 2012-03-26 06:01:42.000000000 -0400
++++ b/src/runtime/run-program.c 2012-03-26 06:02:07.000000000 -0400
+@@ -20,6 +20,7 @@
+ #include <stdlib.h>
+ #include <sys/file.h>
+ #include <sys/types.h>
++#include <sys/wait.h>
+ #include <signal.h>
+ #include <sys/stat.h>
+ #include <fcntl.h>
diff --git a/dev-lisp/sbcl/files/sbcl-1.0.55_no_doc_install.patch b/dev-lisp/sbcl/files/sbcl-1.0.55_no_doc_install.patch
new file mode 100644
index 000000000000..458c637124d7
--- /dev/null
+++ b/dev-lisp/sbcl/files/sbcl-1.0.55_no_doc_install.patch
@@ -0,0 +1,61 @@
+#Patch by Jesus Rivero <neurogeek@gentoo.org>
+#Added: Mar 26, 2012
+#Gentoo Specific, not sent upstream
+
+diff -uNr a/install.sh b/install.sh
+--- a/install.sh 2012-03-26 07:17:28.000000000 -0400
++++ b/install.sh 2012-03-26 07:17:56.000000000 -0400
+@@ -101,52 +101,3 @@
+ # share/man/ manpages, should be the same as man/
+ # share/info/ info files
+ # share/doc/ misc documentation
+-
+-echo
+-echo "Documentation:"
+-
+-# man
+-cp doc/sbcl.1 "$BUILD_ROOT$MAN_DIR"/man1/ && echo " man $BUILD_ROOT$MAN_DIR/man1/sbcl.1"
+-cp doc/sbcl-asdf-install.1 "$BUILD_ROOT$MAN_DIR"/man1/ && echo " man $BUILD_ROOT$MAN_DIR/man1/sbcl-asdf-install.1"
+-
+-# info
+-for info in doc/manual/*.info
+-do
+- cp $info "$BUILD_ROOT$INFO_DIR"/ \
+- && BN=`basename $info` \
+- && DIRFAIL=`install-info --info-dir="$BUILD_ROOT$INFO_DIR" \
+- "$BUILD_ROOT$INFO_DIR"/$BN > /dev/null 2>&1 \
+- || echo "(could not add to system catalog)"` \
+- && echo " info $BUILD_ROOT$INFO_DIR/`basename $info` [$BUILD_ROOT$INFO_DIR/dir] $DIRFAIL"
+-done
+-
+-for info in doc/manual/*.info-*
+-do
+- cp $info "$BUILD_ROOT$INFO_DIR"/ \
+- && echo " info $BUILD_ROOT$INFO_DIR/`basename $info`"
+-done
+-
+-# pdf
+-for pdf in doc/manual/*.pdf
+-do
+- cp $pdf "$BUILD_ROOT$DOC_DIR"/ \
+- && echo " pdf $BUILD_ROOT$DOC_DIR/`basename $pdf`"
+-done
+-
+-# html
+-for html in doc/manual/sbcl doc/manual/asdf
+-do
+- test -d $html && cp -R -L $html "$BUILD_ROOT$DOC_DIR"/html \
+- && echo " html $BUILD_ROOT$DOC_DIR/html/`basename $html`/index.html"
+-done
+-
+-for html in doc/manual/sbcl.html doc/manual/asdf.html
+-do
+- cp $html "$BUILD_ROOT$DOC_DIR"/ \
+- && echo " html $BUILD_ROOT$DOC_DIR/`basename $html`"
+-done
+-
+-for f in BUGS CREDITS COPYING NEWS
+-do
+- cp $f "$BUILD_ROOT$DOC_DIR"/
+-done
+
diff --git a/dev-lisp/sbcl/files/vanilla-module-install-source-gentoo.patch b/dev-lisp/sbcl/files/vanilla-module-install-source-gentoo.patch
deleted file mode 100644
index 92dcff50e16b..000000000000
--- a/dev-lisp/sbcl/files/vanilla-module-install-source-gentoo.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-diff -ur sbcl-0.9.17.orig/contrib/vanilla-module.mk sbcl-0.9.17/contrib/vanilla-module.mk
---- sbcl-0.9.17.orig/contrib/vanilla-module.mk 2006-09-08 08:36:47.000000000 -0500
-+++ sbcl-0.9.17/contrib/vanilla-module.mk 2006-09-29 21:53:50.000000000 -0500
-@@ -5,4 +5,4 @@
- test:: $(MODULE).fasl
-
- install:
-- cp $(MODULE).fasl "$(BUILD_ROOT)$(INSTALL_DIR)"
-+ cp $(MODULE).fasl $(MODULE).lisp "$(BUILD_ROOT)$(INSTALL_DIR)"
-Only in sbcl-0.9.17/contrib: vanilla-module.mk.~1.6.~